Getting up development environment

Developers
2010-01-30
2013-05-28
  • Jason Jackson
    Jason Jackson
    2010-01-30

    Here was my experience:
    (note: Windows 7; xplanner-plus r214)

    Following http://blog.xplannerplus.org/2009/10/setting-up-development-enviroment-for.html I installed JDK 1.6. I started with the 64-bit version, then later uninstalled and installed the 32-bit version because of the error "Cannot load 32-bit SWT libraries on 64-bit JVM" This was happening starting eclipse with -vm pointing to the 64-bit JRE. You need Eclipse running under a JDK JRE for M2Eclipse.

    Tomcat 6, Eclipse, Sysdeo tomcat plugin, Subclipse and M2Eclipse installed..  Checkout Maven Projects from SCM had no svn type the first time around because I didn't install the optional "Maven SCM handler for Subclipse (Optional)". After adding this, I checked out xplanner-plus.

    The workspace had xplanner-plus (branch/v1-0) and xplanner-plus-web-test (trunk/XPlanner-Plus-webtest). I deleted the xplanner-plus project, then used File, Import…, General, Maven Projects with a root of my maven.* directory in my workspace. "/pom.xml - net.sf:xplanner-plus:1.1a1:war" was selected. Now I had xplanner-plus (trunk/xplanner-plus) in the workspace.

    Both projects (xplanner-plus-web-test and xplanner-plus) had Java errors. The first I tackled was related to JavaMail (ie: mail-1.4.jar). The Maven Dependency downloaded a jar with the contents: 301 Moved Permanently… To fix this, I put a dependency in the pom.xml on javax.mail/mail/1.4.3 and added the maven2-repository.dev.java.net repository.

    Next I had a lot of complaints about createJPEGEncoder Access restriction, etc. so this error was turned off with xplanner-plus Properties, Java Compiler, Errors/Warnings, Deprecated and restricted API, Forbidden reference (access rules), Warning. You'll need to "Enable project specific settings" at the top.

    I set the Output folder of xplanner-plus/src (Java Build Path, Source tab) to xplanner-plus/webapp/WEB-INF/classes to be consistent with Maksym. Under Tomcat properties, xplanner-plus was flagged as a Tomcat Project. The Context name was set to xplanner, Can update context…checked, Mark this context…unchecked, Redirect context logger…checked and web application root /webapp.

    For the DevLoader tab, Activate DevLoader…checked and the following were checked:
    /xplanner-plus/webapp/WEB-INF/classes
    all of my .m2/repository EXCEPT jsp-api-2.0.jar and servlet-api-2.4.jar (otherwise, you'll get exceptions!)
    all of my maven.*/trunk/xplanner-plus/*

    The sysdeo tomcat plugin comes with DevLoader.zip. I unzipped this, jarred and copied to Tomcat's lib folder following http://tech-nickel.blogspot.com/2008/10/eclipse-tomcat-sysdeo-and-devloader.html.

    In xplanner-custom.properties, I commented the mysql hibernate configuration and uncommented the embedded persistent HSQLDB configuration. With a tomcat restart, I could login to XPlanner+.

    Hope this helps!
    -Jason