Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

multitouchdisplay N-Trig not working well

Help
2014-06-02
2014-07-01
  • Stefan Schwarz
    Stefan Schwarz
    2014-06-02

    hello!

    first of all a big THX for this program!without xournal i wouldn't try to change to linux :P

    hoever i've a problem with my acer aspire r7-275G running manjaro+kde

    i'm using the latest git version of xournal.

    my settings in /etc/X11/xorg.conf.d/50-wacom.conf are:

    Section "InputClass"
    Identifier "Wacom class"
    MatchProduct "Wacom|WACOM|Hanwang|PTK-540WL|ISD-V4"
    MatchDevicePath "/dev/input/event*"
    Driver "wacom"
    EndSection

    Section "InputClass"
    Identifier "Wacom serial class"
    MatchProduct "Serial Wacom Tablet"
    Driver "wacom"
    EndSection

    Section "InputClass"
    Identifier "Wacom serial class identifiers"
    MatchProduct "WACf|FUJ02e5|FUJ02e7|FUJ02e9"
    Driver "wacom"
    EndSection

    Waltop tablets

    Section "InputClass"
    Identifier "Waltop class"
    MatchProduct "WALTOP"
    MatchIsTablet "on"
    MatchDevicePath "/dev/input/event*"
    Driver "wacom"
    EndSection

    N-Trig Duosense Electromagnetic Digitizer

    Section "InputClass"
    Identifier "Wacom N-Trig class"
    MatchProduct "HID 1b96:0001|N-Trig Pen|N-Trig DuoSense"
    MatchDevicePath "/dev/input/event*"
    Driver "wacom"
    Option "Button2" "3"
    Option "Button3" "2"
    EndSection

    the first problem is, that the secont button of the stylus isn't working but that's no big deal.

    the real problem is, that i'm not able to use multitouch (for scrolling and zooming) isn't working in combination with the stylus.

    i've tried all the settings of xournal but with no result:

    for e.g.:
    xinput on

    most of the time my hand and the stylus are making lines.

    if i use the feature of defining a touchscreen:
    options:
    Virtual core XTES pointer ->both are making lines
    N-trig DuoSense Pen ->both are making lines
    N-Trig DuoSense ->both are making lines
    Core Pointer ->both are making lines

    also touchscreen as handtool and pen disable touchscreen doesn't help.

    it seems that xournal can't see the difference between pen and touch :(
    and i've no clue what i could do :(

    I'm also using touchegg for multitouchgesture, that works quite well but doesn't change the behaviour of xournal.

    i hope you can help me with my problem because i really whant to delete my windowspartition :P

    edit:

    i've also tried the gtk3 version.
    with gtk3 it's working! the multitouch and the stylus like it should.

    however the line of the stylus appears only after lifting the stylus from the screen which is really annoying :(
    also the lasso isn't working...

     
    Last edit: Stefan Schwarz 2014-06-02
  • Denis Auroux
    Denis Auroux
    2014-07-01

    Gtk2 really doesn't understand multitouch at all, so the 'official' version of xournal won't support multitouch gestures. However it should be able to tell the difference between touch and pen. I am surprised by the outcome of designating as touchscreen device

    N-Trig DuoSense -> both are making lines

    I was going to expect that with this setting, and with "touchscreen as handtool" enabled, touch would give scroll gestures and quite possibly pen would also give scroll gestures instead of drawing lines -- because, unfortunately, right now xournal tests whether the device name contains the chosen device as a substring, instead of being strictly equal to it. (This is left over from earlier code that autodetected things; I wasn't aware that on some systems the touch device name is a strict substring of the pen device name. The issue is easy to fix and, if you confirm that you can get "touchscreen as handtool" to work properly with this setting except the pen then also becomes a handtool, I'll fix it).

    Denis