Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

#246 Fatal error with PHP5.3.x

open
nobody
Legacy (179)
5
2014-04-04
2010-03-31
K.Ono
No

PHP 5.3 does not seem to allow calling the parent class constructor
with its class name, i.e. parent::CLASS_NAME(), if it is not already defined.
This causes fatal error on most pages.

html/modules/legacy/kernel/Legacy_Module.class.php
*** 399,404 ****
--- 399,409 ----
*/
var $mAdminMenu = null;

+ function Legacy_ModuleAdapter(&$module)
+ {
+ parent::Legacy_AbstractModule($module);
+ }
+
/**
* @public
* @brief This method is called back by the action search feature in the control

Discussion

  • K.Ono
    K.Ono
    2010-03-31

    The error:

    Fatal error: Call to undefined method Legacy_ModuleAdapter::Legacy_ModuleAdapter()

     
  • K.Ono
    K.Ono
    2010-03-31

    • priority: 5 --> 7
     
  • minahito
    minahito
    2010-03-31

    Thank you for reporting.
    XCL 2.1.8 can not run PHP 5.3.x and later. Developers didn't check it.

    https://sourceforge.net/apps/mediawiki/xoopscube/index.php?title=Download

    > Recommended Requires
    > PHP:4.3.3 - 5.2.12

    But now, XCL gets code to run on PHP 5.3.x. The next version will employ this patch. Thank you very much!

     
  • minahito
    minahito
    2010-03-31

    In addition,
    I think it's difficult to guarantee PHP 5.3.x supporting perfectly, because XCL 2.2 includes many many patches. Even if the next version employ this patch, our recommended requires should not include PHP 5.3.x and later.

    Or developers should copy many patches from the 2.2 branch?
    (But, XCL 2.1.8 has to support PHP 4.3.3 - 5.3.x. This is more wide range than XCL 2.2)

    What do you think about it?

     
  • K.Ono
    K.Ono
    2010-03-31

    I think we should at least fix those fatal errors even if we can't support 5.3.x
    completely. XAMPP now comes with PHP 5.3.1 enabled by default and that
    could be worth considering.

    I found that Marijuana has already posted minimum patches for 5.3.x on his blog.
    http://marijuana.xsrv.jp/modules/wordpress/?p=268

     
  • minahito
    minahito
    2010-03-31

    Ok, I agree. We don't change the recommended requires, but try to remove fetal errors. Thank you for the useful patch. If you find useful patch or have some idea, can you report it? You can report it via the trackers, the forums and so on.

    Note that the 2.1.x developers do nothing themselves, if our trackers are empty. Instead of it, we try to employ almost all patches and requests.

    Thanks in advance.

     
  • minahito
    minahito
    2010-03-31

    Priority 7 (SHOULD have) --> Priority 5 (COULD have), because the recommended requires is not changed. But this suggestion is a good idea. So the next version will employ this patch.

     
  • minahito
    minahito
    2010-03-31

    • priority: 7 --> 5