#247 Latest Core check

XOOPS_2.x
open
nobody
Core (214)
5
2012-09-25
2006-11-28
davidl2
No

After having some recent posts about hacked sites, caused by users who have updated - I would like to request this feature:

A latest version check, which will check to see if the user is using the latest stable release of Xoops, and needs to update or not.

Some recent modules have added this feature - and this would also help put the responsibility of updating the core back onto the user.

Discussion

  • Mao
    Mao
    2006-11-29

    Logged In: YES
    user_id=1183441
    Originator: NO

    Can't xoops_md5.php be used for this?
    Or I'm misreading at all?

    banned,

     
  • Bandit. S.
    Bandit. S.
    2006-12-01

    Logged In: YES
    user_id=1426285
    Originator: NO

    i think the poster is talking about a page/ or notification that tells them their version is old. that is built in to the administration section.

    for example. nucleus has a page that checks your current installed version with the current stable version of the script and then gives you a download link. (i think that was how it was done.. its been a while since i used nucleus. )

    what i believe that one of the benefits from this is that i dont have to go searching on the site (but then again its easy to find the current version of any download when you go to their site).
    another is that some people are busy and dont want to open another browser window. or tell them self.. 'yea ill check later'.. or they keep on checking and then stop.. and become really involved in their site and dont know what is going on in the XooPS world.

     
  • davidl2
    davidl2
    2006-12-01

    Logged In: YES
    user_id=1318892
    Originator: YES

    Thanks Bandit - that's exactly what I mean :)

     
  • GibaPhp
    GibaPhp
    2007-05-08

    Logged In: YES
    user_id=1129857
    Originator: NO

    Exelent ideas :-)

    About md5 check, too resolv problem if code check last version and warning messages.
    But not resolv day a day site if new version stable is published. :-)