Installing new packages that are not in Fink?

Help
2007-04-27
2013-06-03
  • Ok, I have a few packages such as libgdkmm, dlcompat-20030629, and libpthread that are not in Fink even after I searched for them. I am an extreme newbie to all of this coding stuff and I do not know how to install packages outside of Fink, into Fink so that I can then search for new packages in Fink in order to install them through Fink. Are you with me? I don't know the terminology here so sorry if I am not being very clear. Basically, I want to install those three packages into Fink so I can then install them with Fink. How can I tell Fink to find them so I can install them?

    Cheers,
    James

     
    • How did you find this forum? It has nothing to do with Fink, and I am probably the only person in the world that is still reading it. It has been dead for 3 years, and before that it was dedicated to developing X11 for the Mac, before Apple came out with its version of X11 in 2003. You will have more success asking your questions on the fink-beginners mailing list.

      Anyway, you cannot install packages "outside of Fink into Fink". Fink can install only packages it knows about. What can happen is that *your* installation of Fink does not know about certain packages because it hasn't been updated. The way to update is to run "fink selfupdate-rsync".

      The packages that you are talking about don't exist under that name:
      - Libraries that have libgdkmm in their name come with packages that have "gtkmm2" in their name, for example gtkmm2-shlibs or gtkmm2.4-shlibs, depending on the version needed.
      - dlcompat does not exist for recent versions of MacOSX any more, because it now comes with the system. If you installed Fink for MacOSX 10.2, dlcompat should be in available in your Fink. For 10.3, it still exists but is not needed. For 10.4 it does not exist.
      - libpthread is not in Fink, because it comes with MacOSX anyway.

       
      • ah! Thank you very much, what you have explained makes sense to me. And I didn't realise this forum was so dead, I just clicked on one of the Forum links on Fink's main help page, you know? Anyway, cheers again for the information. You may be the only person who still restlessly haunts this dead discussion board, but you helped loads. It works now. :-)

         
    • Oh, and the reason why I asked about these three in particular is because this logging program I am trying to install said I needed them. I installed the two (not libpthread) and then I ran the installation process; firstly, it all checked "yes" about having the required files installed, but then it ran a pre-check script for trying to locate the libpthread files, and it came out like this (this is in Terminal, not Fink anymore):

      checking for library containing pthread_create... none required
      checking whether gcc accepts -pthread... no
      configure: WARNING: ***************************
      configure: WARNING: * PTHREAD ARE REQUIRED !! *
      configure: WARNING: ***************************

      P.S. Must be depressing to linger around a discussion board that was once active and now is useless (besides my posts).

       
      • > checking whether gcc accepts -pthread... no

        You should look in the config.log file for the real error. Apple's gcc supports the -pthread flag, so the real error may be something else. But then I don't even know what version of OSX and of gcc you are running. It could also be that your gcc is too old.

        >P.S. Must be depressing to linger around a discussion board that was once active and now is useless (besides my posts).

        I am subscribed (too lazy to unsubscribe), so I get notified whenever a new post shows up - no need for lingering.

         
    • I am running 10.4.9 with Linux Kernel 8.9.0 and gcc version 4.0.1 (Apple Computer, Inc. build 5367). As for what the config.log regurgitated from the -pthread error:

      Default processor set: 95 tasks, 280 threads, 1 processors
      Thread model: posix
      Thread model: posix
      Thread model: posix
      configure:27986: checking for library containing pthread_create
      configure:28241: checking whether gcc accepts -pthread
      configure:28269: gcc -o conftest -g -O2   -pthread conftest.c -lltdl  >&5
      powerpc-apple-darwin8-gcc-4.0.1: unrecognized option '-pthread'
      |          #include <pthread.h>
      |                pthread_create(NULL, NULL, NULL, NULL);
      configure:28301: WARNING: * PTHREAD ARE REQUIRED !! *
      ac_cv_search_pthread_create='none required'

      I hope this helps!

       
      • Contrary to what I said (and what Apple's own documentation says), Apple's gcc does not support the -pthread flag, hence the message "unrecognized option '-pthread'". But as you showed, this only leads to a warning, because threading works anyway without this flag. So you shouldn't worry about this, and if there is a failure, the error must be elsewhere.

         
    • So are you saying I can just go ahead and "make install" for the rest of the installation process, ignoring any such errors?