gcc 4.0.1 vs gcc 4.0.0

Help
2005-12-29
2013-06-03
  • Attila Szegedi
    Attila Szegedi
    2005-12-29

    Here's a problem when compiling packages from source (Mac OS X 10.4.3, latest XCode with gcc 4.0.1):

    ----------
    The following package will be installed or updated:
    svn-ssl-shlibs
    The following 2 additional packages will be installed:
    neon24-ssl neon24-ssl-shlibs
    Do you want to continue? [Y/n]
    Failed: This package must be compiled with GCC 4.0.0, but you currently have
    GCC 4.0.1 selected.  To correct this problem, run the command:

        sudo gcc_select 4.0

    (You may need to install a more recent version of the Developer Tools to be
    able to do so.)
    ----------

    Any idea? I tried "downgrading" to gcc 4.0.0 using the XCode installer from the Mac OS X install CD, but "gcc 4.0.0" checkbox was grayed out... If anyone knows how can I either
    a) patch the source files to overcome the problem
    b) have gcc 4.0.1 lie about its version number
    c) any other solution

    I'd be grateful, thanks.

     
    • You should run "fink selfupdate-rsync". This will bring you up-to-date versions of fink and of neon24-ssl, either of which will make this error message disappear.

      (BTW, what does this have to do with XonX?

       
    • Attila Szegedi
      Attila Szegedi
      2005-12-30

      Ok, I'm now doing the selfupdate. BTW, pardon my ignorance, but what is "XonX"?

       
      • XonX is the sourceforge project to which belongs this forum. Just look at the headers of this page.