Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

Xineliboutput and StretchBlit???

Help
SergArb
2007-01-22
2013-05-30
  • SergArb
    SergArb
    2007-01-22

    I use Radeon9200SE on TV via RGB, when mode is interlaced half of screen is black :(
    I found that in softdevice i can set Pixel Format: YUY2 & Use StretchBlit: on, then picture is ok :) How can i do same with Xineliboutput?

    P.S. Sorry for my english...
    Best Regards.

     
    • Maybe hardware or driver does not support video overlays in interlaced modes (?). I had similar problem with i815 few years ago (hardware stretched overlaid video to double height).

      It might be possible to force xine-lib directfb driver to use StretchBlit by changing setting video.device.directfb_layer_id in xine-lib config file ($HOME/.xine/config_xineliboutput). If selected layer does not not support video overlay, directfb driver should use StretchBlit.

      I don't think it is possible to change pixel format by changing any setting (if not in directfb settings ?). Only way I can tell now is using tvtime deinterlacer with setting cheap_mode=0, it will convert video to yuy2 before de-interlacing.

       
    • SergArb
      SergArb
      2007-01-23

      It's works!!! Thank you! Only need set "video.device.directfb_layer_id:0"