HD channels on vdr 1.7.8, cvs on AMD64

2009-07-18
2013-05-30
  • Switching to (moving) HD channels does not work. vdr-sxfe and xine do crash with a segfault in libavcodec when accessing xineliboutput plugin through xvdr. This does not happen when I use xine with http connection so I guess the bug is not related to libavcodec but to the xvdr plugin of xine. It does also not happen when I switch to ARD or ZDF demo channels with HD still pictures. Any idea where to search for the bug? I can provide any debug output you need.

    Jul 18 12:57:27 shinto vdr: [14222] [xine..put] Client 0 connected: 127.0.0.1:51444
    Jul 18 12:57:27 shinto vdr: [14222] [xine..put] cxSocket: setsockopt(SO_SNDBUF): got 262142 bytes
    Jul 18 12:57:27 shinto vdr: [14222] [xine..put] Trying PIPE connection ...
    Jul 18 12:57:27 shinto vdr: [14222] creating directory /video/plugins/xineliboutput/pipes.14212
    Jul 18 12:57:27 shinto vdr: [14222] removing /video/plugins/xineliboutput/pipes.14212
    Jul 18 12:57:27 shinto vdr: [14222] [xine..put] cBackgroundWriterI initialized (buffer 512 kb)
    Jul 18 12:57:27 shinto vdr: [14222] [xine..put] cTcpWriter initialized (buffer 512 kb)
    Jul 18 12:57:27 shinto vdr: [14222] [xine..put] Pipe open
    Jul 18 12:57:29 shinto vdr: [14222] [xine..put] Client connection 0 closed
    Jul 18 12:57:29 shinto kernel: [1187882.697564] vdr-sxfe[16452]: segfault at d40 ip 00007f705f2682e8 sp 00007f70581bcb60 error 4 in libavcodec.so.52.32.0[7f705f076000+495000]
    Jul 18 12:57:29 shinto vdr: [14222] [xine..put] Closing connection 0