#5 Connection Reset by peer on authentication

closed
5
2003-05-02
2003-05-02
Anonymous
No

Replacing the drivers on a RedHat 9 box with the
vnc-4.3.0.3 module creates no problems on the box. The
machines starts listening on 5900 and on connection
asks for authentication. As soon as the password is
entered, the connection dies with a "Connection Reset
by Peer".

The following is taken from the XFree86 log file

(II) 02/05/2003 14:06:03
(II) Got connection from client 10.0.0.1
(II) 02/05/2003 14:06:03
(II) Protocol version 3.3
(II) 02/05/2003 14:06:06
(II) Full-control authentication passed by 10.0.0.1
(II) 02/05/2003 14:06:06
(II) Pixel format for client 10.0.0.1:
(II) 02/05/2003 14:06:06
(II) 8 bpp, depth 8
(II) 02/05/2003 14:06:06
(II) true colour: max r 7 g 7 b 3, shift r 0 g 3 b 6
(II) 02/05/2003 14:06:06
(II) rfbSetTranslateFunction: server bits per pixel not
8, 16 or 32
(II) 02/05/2003 14:06:06
(II) Client 10.0.0.1 gone
(II) 02/05/2003 14:06:06
(II) Statistics:
(II) 02/05/2003 14:06:06
(II) framebuffer updates 0, rectangles 0, bytes 0

There are no firewalls anywhere between the machines.

Any ideas?

Discussion

  • Alan Hourihane
    Alan Hourihane
    2003-05-02

    • assigned_to: nobody --> alanh
    • status: open --> closed
     
  • Alan Hourihane
    Alan Hourihane
    2003-05-02

    Logged In: YES
    user_id=2372

    You are running with 24bits per pixel. You need to change to
    32bits per pixel.

     
  • Philip Correia
    Philip Correia
    2003-05-02

    Logged In: YES
    user_id=770067

    That seems to do it. Thanks :)