#390 XDvi 22.84.16 (Xaw toolkit): Failed assertion in hypertex.c

incorrect behaviour
open
nobody
None
5
2014-08-12
2014-03-12
Alexander Held
No

When selecting pages from the menu, the following error occurs randomly:

************************************************************
XDvi 22.84.16 (Xaw toolkit): Failed assertion:
../../../texk/xdvik/hypertex.c:963: "info->anchors != NULL": info->anchors
should have been allocated before
Aborting now. Please report this as a bug to:
http://sourceforge.net/tracker/?group_id=23164&atid=377580
If a core dump has been produced, please invoke:
gdb xdvi.bin core
Then type "bt", and include the resulting output in your bug report.
************************************************************
Aborted (core dumped)

following the instructions produces:

*user*@*machine*:~$ gdb xdvi.bin core
GNU gdb (Ubuntu/Linaro 7.4-2012.04-0ubuntu2.1) 7.4-2012.04
Copyright (C) 2012 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-linux-gnu".
For bug reporting instructions, please see:
<http://bugs.launchpad.net/gdb-linaro/>...
Reading symbols from /usr/bin/xdvi.bin...(no debugging symbols found)...done.
/home/*user*/core: No such file or directory.
(gdb) bt
No stack.
(gdb)

Discussion

  • Paul Vojta
    Paul Vojta
    2014-04-04

    I haven't been able to reproduce the problem. Are there any unusual circumstances that affect presence of the bug (for example, large dvi file, quickly switching pages, or quickly selecting a page after starting up xdvi)?

    I see that you are using Ubuntu. Which version of Ubuntu is it?