Install trouble regarding qt3

Help
Espen
2004-10-22
2013-04-25
  • Espen
    Espen
    2004-10-22

    I was trying to install XDrawChem on my system, but it seems the qt version is too new? how do I solve this problem?

    [root@m035d xdrawchem-1.9]# ./configure
    checking for a BSD-compatible install... /usr/bin/install -c
    checking whether build environment is sane... yes

    ***etc. etc. etc.***

    checking for ar... /usr/bin/ar
    checking for X... libraries /usr/X11R6/lib, headers /usr/X11R6/include
    checking QTDIR... /usr/lib/qt3/
    checking Qt version... grep: /usr/lib/qt3//include/qglobal.h: No such file or directory
    configure: error: *** Don't know how to handle this Qt major version
    [root@m035d xdrawchem-1.9]#

     
    • Espen
      Espen
      2004-10-22

      ps. I run mandrake 10.0
      pps. I am new to linux

       
    • Matthew
      Matthew
      2004-10-25

      Do you have the qt3 devel rpms installed?  Does that file /usr/lib/qt3//include/qglobal.h exist? I am running mandrake 10 for AMD64 and I don't get errors untill link time.  Yes they do seem to be related to linking with the qt libs.  I have been running mandrake for years, and more often than not ,regardless of version, have some sort of major trouble compiling any qt or kde based package. Except strangely xdrawchem under mandrake 9.2 for i586.  Of course naturaly that old binary won't run anymore because the upgrade replaced my old libs with new incompatible versions!  *beats head against table*