Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

#1458 Syntax error in configure

open
nobody
None
5
2010-07-02
2010-07-02
Anonymous
No

Hello,

I am trying to build XChat on a Gentoo server. The ./configure script exit with this error :
checking for GLIB - version >= 2.0.3... yes (version 2.24.1)
./configure: line 17207: syntax error near unexpected token `2.10.0,'
./configure: line 17207: `AM_PATH_GTK_2_0(2.10.0, havegtk=yes, havegtk=no)'

I use the SVN version.
Juste before, I built on my Ubuntu desktop, it worked fine. (I checked : there no change in the SVN repository between the two builds).

I temporary solved the problem replacing
AM_PATH_GTK_2_0(2.10.0, havegtk=yes, havegtk=no)
by
AM_PATH_GTK_2_0(2.10.0, havegtk=yes, havegtk=no)
havegtk=no

My ./configure options are (for the server build) :
./configure --enable-ipv6 --enable-openssl=/usr/lib/libgnutls-openssl.so.26 --disable-perl --disable-xlib -enable-textfe --disable-gtkfe

ProgVal

Discussion