Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

#3 Compilation problem on macos 10.5.8

closed
nobody
None
5
2010-03-13
2009-12-17
PeterC
No

Hello

I tried to install the latest binary but that does not work. When starting it crashes with

MacPc:xca pc$ /Volumes/xca-0.7.0/xca.app/Contents/MacOS/xca
dyld: Library not loaded: /usr/lib/libcrypto.0.9.8.dylib
Referenced from: /Volumes/xca-0.7.0/xca.app/Contents/MacOS/xca
Reason: image not found
Trace/BPT trap

Reason is probably I have an earlier version of libcrypt (0.9.7)

So I tried to build from the sources

Then I get

/usr/bin/g++-4.0 -c -pipe -g -Wall -W -DQT_GUI_LIB -DQT_CORE_LIB -DQT_SHARED -I/opt/local/libexec/qt4-mac/mkspecs/macx-g++ -I. -I/opt/local/libexec/qt4-mac/lib/QtCore.framework/Versions/4/Headers -I/opt/local/libexec/qt4-mac/include/QtCore -I/opt/local/libexec/qt4-mac/include/QtCore -I/opt/local/libexec/qt4-mac/lib/QtGui.framework/Versions/4/Headers -I/opt/local/libexec/qt4-mac/include/QtGui -I/opt/local/libexec/qt4-mac/include/QtGui -I/opt/local/libexec/qt4-mac/include -I. -Ilib -Iwidgets -I. -I. -F/opt/local/libexec/qt4-mac/lib -o db_key.o lib/db_key.cpp
lib/pki_evp.h:43: error: ISO C++ forbids declaration of 'EC_builtin_curve' with no type
lib/pki_evp.h:43: error: expected ';' before '*' token
make: *** [db_key.o] Error 1

Any guidance?

Thanks!

Peter

Discussion

  • XCA requires OpenSSL 0.9.8
    You either need OS X 10.6 "Snow Leopard" or install OpenSSL 0.9.8 by hand.

     
    • status: open --> closed