Compile problem - CentOS 5.5

Help
sapittman
2011-02-24
2013-03-09
  • sapittman
    sapittman
    2011-02-24

    I installed the latest Qt4, and the remaining required packages and got clean configure output…


    Configuring XCA 0.9.0

    Found: QtCore/QObject at /usr/local/Trolltech/Qt-4.7.1/include
    Found: libQtGui.so at /usr/local/Trolltech/Qt-4.7.1/lib
    Found: libltdl.so at /usr/lib
    Found: openssl/opensslv.h at /usr/include
    Found: libcrypto.so at /usr/lib

    The Versions of the used libraries are:
            OpenSSL 0.9.8e-rhel5 01 Jul 2008 0x90802fL
            QT: 4.7.1
    /usr/bin/linuxdoc
    GNU Make 3.81

    A usable 'make' executable was found in /usr/bin/make

    Running 'make' however, yields the following errors:

    gcc -I. -I.. -I/tmp/xca-0.9.0/ui -I/usr/local/Trolltech/Qt-4.7.1/include -Wall -ggdb -O2  -L/usr/local/Trolltech/Qt-4.7.1/lib  -c dbkey.cpp -o db_key.o
    pki_evp.h:40: error: ISO C++ forbids declaration of 'EC_builtin_curve' with no type
    pki_evp.h:40: error: expected ';' before '*' token
    make: ***  Error 1


    Any ideas?

     
  • sapittman
    sapittman
    2011-02-26

    Christian-

    It took me a while to figure out how to use that patch (I'm not a programmer by any stretch of the imagination, and have never encountered git) but I did, and after doing a 'make distclean' and rerunning 'configure', it compiled and runs great.

    Thanks a ton for the fast turn-around on my question, and most of all, the slick utility!