Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

cannot load the plugin

Help
kknull
2008-06-22
2013-04-08
  • kknull
    kknull
    2008-06-22

    Hi.
    I am running
    xbmc-mythtv 0.20.34
    xbmc svn 13660
    mythtv 0.21

    When I click to load "xbmcmythtv" script in xbmc the "loading" message box appears and disappears in 1 second.
    I see the "(running)" text for 1 second. Then nothing...

    thanks. :D

    KKnull

     
    • lingenfr
      lingenfr
      2008-06-22

      Are all of your settings correct? Have you checking the folder/directory settings. I had a similar problem when mine were incorrect. There are other smarter folks here who may have a better idea.

       
      • kknull
        kknull
        2008-06-22

        yes I think they are correct. I set correctly too...

         
        • kknull
          kknull
          2008-06-22

          I set samba*

           
    • David Teirney
      David Teirney
      2008-06-22

      Best bet is to turn on debug logging within XBMC and then have a look at that log file (found in the root of your XBMC installation) to see if that gives you any pointers.

      Or move onto use the new built-in myth:// protocol support. http://xbmc.org/forum/showthread.php?t=2297

       
      • lingenfr
        lingenfr
        2008-06-22

        In case you don't know how to set debug mode, you can find the information here:

        http://xbmc.org/wiki/?title=DVDPlayer#Bug_Reporting

        Look under the section 'Log File' and it will tell you what to do. I would suggest that you turn debug on. They restart your xbox and try to access your shares. Let it fail once or twice and then FTP your xbmc.log file to your computer and paste it here. Good luck.

         
    • kknull
      kknull
      2008-06-24

      ok, I managed to get the debug code.
      Here is the complete log:  http://rafb.net/p/ioOLVN67.html
      and here I think there is the script error: http://rafb.net/p/azfEAm32.html

      KKnull.

       
      • kknull
        kknull
        2008-06-24

        I think the error of "14:09:26 T:2644224912 M:954920960    INFO: IOError: [Errno 2] No such file or directory: '/home/kk/.xbmc/scripts/xbmcmythtv/skin/shared/pal/vars.xml\r'"

        is somewhere in "findSkinFile" function in mythtvutil.py (line 142)

         
        • David Teirney
          David Teirney
          2008-06-24

          Perhaps things have moved along since I last looked, but I didn't think that the Python scripting stuff had been ported into the Linux version of XBMC yet.

          Have you had the mythtv script working in Linux before? If so, perhaps try logging this problem with the Linux XBMC forum (http://xbmc.org/forum/forumdisplay.php?f=52) to see if anyone there can help as it looks like a Python issue loading a file before it really gets into the MythTV script proper.

           
    • lingenfr
      lingenfr
      2008-06-25

      Maybe I missed something, but who said anything about the Linux version? For me, I doubt I would even think about using XBMC on one of my linux boxes, I would just run myth and plugins.I replaced my linux mythfrontend with an xbox and xbmc/xbmcmythtv because I wanted a cheaper, simpler, smaller solution.

       
      • David Teirney
        David Teirney
        2008-06-26

        The log file that was posted suggested that XBMC was running under GNU Linux.

        I'm moving to XBMC through Linux soon so I can play HD content. Will be using the myth:// protocol.

        XBMC has much better support for other media than the plugins available for Myth TV. There's also a Google Summer of Code project for XBMC to build a front end to backend PVR solutions targetting Myth TV first up.