Recording will not play

Help
mike
2008-07-24
2013-04-08
  • mike
    mike
    2008-07-24

    Okay XBMC and script is up and running and I see listings and recorded programs, problem is that the script does nothing when it is supposed to play the program.

    About my set up.

    I have two harddrives with recordings on both.  I have created a directory and using unionfs combined the contents of both harddrives into one directory.  So that /home/user/recordings point to /var/lib/mythtv/recordings and /media/hdb1/ so /home/user/recordings contains the contents of both directories. 

    From what I read in the log, the script is asking for the file, and mythtv is telling the xbox that the recording is at /var/lib/mythtv/nameoffile.mpg and so the script gets confused and does not know where to get the file.

    all directories are sent to share under samba.  I tested the connection in xbmc as a samba connection and it works fine, and video was streamed.

    Here is the log

    2008-07-23 20:05:56.593000 [33] msg=[34      QUERY_RECORDER 2[]:[]GET_RECORDING]

    2008-07-23 20:05:56.594000 [33] < sendMsg

    2008-07-23 20:05:56.594000 [33] > readMsg()

    2008-07-23 20:05:56.595000 [33] reply len: 544

    2008-07-23 20:05:56.596000 [33]  i=0 n=544

    2008-07-23 20:05:56.600000 [33] < readMsg: [So You Think You Can Dance[]:[][]:[]The top eight dancers are paired with new partners to perform for the judges.[]:[]Reality[]:[]1388[]:[]388[]:[]WNYW[]:[]WNYW[]:[]/var/lib/mythtv/recordings/1388_20080723200000.mpg[]:[]0[]:[]0[]:[]1216857600[]:[]1216864800[]:[]0[]:[]0[]:[]0[]:[]mythtv[]:[]1[]:[]2[]:[]1[]:[]5[]:[]-2[]:[]20[]:[]3[]:[]47[]:[]6[]:[]1216857600[]:[]1216864800[]:[]0[]:[]0[]:[]Default[]:[]0[]:[][]:[]EP00751700[]:[]EP007517000077[]:[]1216857547[]:[]0.000000[]:[]2008-07-23[]:[]1[]:[]Default[]:[]0[]:[]0[]:[]LiveTV[]:[]1[]:[]0[]:[]1]

    2008-07-23 20:05:56.600000 [33] < sendRequest

    2008-07-23 20:05:56.612000 [33] > sendRequest

    2008-07-23 20:05:56.616000 [33] > sendMsg

    2008-07-23 20:05:56.617000 [33] msg=[16      QUERY_FREE_SPACE]

    2008-07-23 20:05:56.617000 [33] < sendMsg

    2008-07-23 20:05:56.618000 [33] > readMsg()

    2008-07-23 20:05:56.619000 [33] reply len: 182

    2008-07-23 20:05:56.619000 [33]  i=0 n=182

    2008-07-23 20:05:56.620000 [33] < readMsg: [mythtv[]:[]/media/hdb1[]:[]1[]:[]-1[]:[]2[]:[]0[]:[]117161008[]:[]0[]:[]115823052[]:[]mythtv[]:[]/var/lib/mythtv/recordings[]:[]1[]:[]-1[]:[]3[]:[]0[]:[]190830456[]:[]0[]:[]187566520]

    2008-07-23 20:05:56.621000 [33] < sendRequest

    2008-07-23 20:05:56.629000 [33] > sendRequest

    2008-07-23 20:05:56.631000 [33] > sendMsg

    2008-07-23 20:05:56.634000 [33] msg=[10      QUERY_LOAD]

    2008-07-23 20:05:56.634000 [33] < sendMsg

    2008-07-23 20:05:56.635000 [33] > readMsg()

    2008-07-23 20:05:56.636000 [33] reply len: 22

    2008-07-23 20:05:56.636000 [33]  i=0 n=22

    2008-07-23 20:05:56.637000 [33] < readMsg: [2.23[]:[]1.87[]:[]1.18]

    2008-07-23 20:05:56.637000 [33] < sendRequest

    2008-07-23 20:05:56.638000 [33] ['2.23', '1.87', '1.18']

    2008-07-23 20:05:56.664000 [33] >getMythSetting(mythfilldatabaseLastRunStart,None)

    2008-07-23 20:05:56.677000 [33] <getMythSetting [2008-07-23 03:22]

    2008-07-23 20:05:56.677000 [33] >getMythSetting(mythfilldatabaseLastRunEnd,None)

    2008-07-23 20:05:56.679000 [33] <getMythSetting [2008-07-23 03:22]

    2008-07-23 20:05:56.683000 [33] >getMythSetting(mythfilldatabaseLastRunStatus,None)

    2008-07-23 20:05:56.684000 [33] <getMythSetting [Successful.]

    2008-07-23 20:05:56.698000 [33] > mythtv.Connection.getPendingRecordings(QUERY_GETALLPENDING)

    2008-07-23 20:05:56.700000 [33] > sendRequest

    2008-07-23 20:05:56.700000 [33] > sendMsg

    2008-07-23 20:05:56.701000 [33] msg=[25      QUERY_GETALLPENDING[]:[]2]

    2008-07-23 20:05:56.702000 [33] < sendMsg

    2008-07-23 20:05:56.702000 [33] > readMsg()

    2008-07-23 20:05:56.911000 [33] reply len: 352457

    2008-07-23 20:05:56.917000 [33]  i=0 n=352457

    2008-07-23 20:05:56.919000 [33]  i=62584 n=352457

    2008-07-23 20:05:56.921000 [33]  i=74320 n=352457

    2008-07-23 20:05:56.924000 [33]  i=101704 n=352457

    2008-07-23 20:05:56.926000 [33]  i=129088 n=352457

    2008-07-23 20:05:56.928000 [33]  i=162992 n=352457

    2008-07-23 20:05:56.935000 [33]  i=226888 n=352457

    2008-07-23 20:05:56.937000 [33]  i=249056 n=352457

    2008-07-23 20:05:56.939000 [33]  i=272528 n=352457

    Any ideas?

    Thanks in advance

     
    • mike
      mike
      2008-11-30

      I think I'm having this problem too.  Was there any resolution?

       
      • lingenfr
        lingenfr
        2008-12-01

        kaptain, the board is pretty slow. Others may be able to help. Start by checking your log in your xbmc directory. If the problem doesn't jump out at you, post your log.

         
    • mike
      mike
      2008-12-02

      I got the feeling that was the case.  What product did everyone start using?  I think this script is better than the native xbmc support. So which log do I look too?  How do I turn on debugging?  My xbmcmythtv log doesn't seem to have anything exciting except that debugging is off.    Sounds like I'm going to have to go peeking around in the code soon.

       
    • mike
      mike
      2008-12-02

      ok I figured out the debugging thing (edit default.py?) 

       
    • mike
      mike
      2008-12-02

      Fixed it.  I updated to the latest from cvs and that seems to have done it.  Thanks for the response