Yes. I made PBS 2.0.8 compatible with both Requests 0.13.2 and 1.0.4.

- stacked


On Sun, Dec 30, 2012 at 6:27 AM, Benjamin Bertrand <beenje@xboxmediacenter.com> wrote:
Just to be sure, is it still compatible with requests 0.13.2?

That's the impression I have as you didn't update the requests version in the addon.xml.
If that's the case, it's all good, and I will do the update.


On Sat, Dec 29, 2012 at 11:49 PM, stacked xbmc <stacked.xbmc@gmail.com> wrote:
I just read the "script.module.requests API change" email. Please ignore the pull for PBS v2.0.7 and pull v2.0.8 instead.

Thanks

addon: plugin.video.pbs 
version: 2.0.8 
tag: v2.0.8 
xbmc version: frodo 
 
- Updated code to be compatible with Requests v1.0.4 



On Sat, Dec 29, 2012 at 1:17 AM, stacked.xbmc@gmail.com <stacked.xbmc@gmail.com> wrote:
addon: plugin.video.pbs
version: 2.0.7
url: git://github.com/stacked/plugin.video.pbs.git
tag: v2.0.7
xbmc version: frodo

- Fixed duration time issue
- Fixed 'argument 1 must be unicode or str' error
- Fixed 'NoneType' has no len()" error in find_videos
- Fixed redirect_url error



------------------------------------------------------------------------------
Master Visual Studio, SharePoint, SQL, ASP.NET, C# 2012, HTML5, CSS,
MVC, Windows 8 Apps, JavaScript and much more. Keep your skills current
with LearnDevNow - 3,200 step-by-step video tutorials by Microsoft
MVPs and experts. SALE $99.99 this month only -- learn more at:
http://p.sf.net/sfu/learnmore_122912
_______________________________________________
Xbmc-addons mailing list
Xbmc-addons@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/xbmc-addons