Hi all,

Requests v1.0.0 was released a few days ago and defines the public API.
Requests 0.13.2 is currently available in eden and frodo repos and is used by the following plugins:
plugin.video.arretsurimages
plugin.video.classiccinema
plugin.video.filmarkivet
plugin.video.m6groupe
plugin.video.newyorktimes
plugin.video.nrk
plugin.video.pbs
plugin.video.redditmusic

I was thinking about updating it to v1.0.4 for frodo but there are some API changes.
See http://kennethreitz.org/announcing-requests-v100.html for details.

You can test your plugin with the new requests available here: https://github.com/beenje/script.module.requests/archive/v1.0.4.zip

Would all the devs impacted be ok to update their plugin (if needed) for this new release?

That would be a good occasion to update the plugins for frodo (with xbmc.python 2.1.0) ;-)
I could wait a few days for the updates before to do the push.

If your plugin is impacted, please reply.

Thanks

beenje