Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

can not schedule a record

2007-08-07
2013-04-30
  • I have got xdtv installed on ubuntu feisty 7.04 by using the debian stable repository the version installed is 2.4.0-0.5
    (the sid repository will not install due to ubuntu is using old library's ver 2.4.0-0.7)
    when i try to schedule a record it flashes up a window only
    I checked that at and cron are install, both are
    any help would be greatly appreciated
    thanks Dave

    ps the terminal info is

    This is xdtv 2.4.0 running on Linux/i686 (2.6.20-15-generic).
    scandir: No such file or directory
    filename = /home/david/.xdtv/xdtvrc
    /dev/video0 [v4l2]: no overlay support
    xdtv_v4l-conf had some trouble, trying to continue anyway
    Warning: Missing charsets in String to FontSet conversion
    wmhooks: netwm detected
    wmhooks: netwm state above supported
    wmhooks: netwm fullscreen supported
    wmhooks: nothing found...
    DGA: server=2.0, include=2.0
    VidMode: server=2.2, include=2.2
      available video mode(s): 1024x768 800x600 640x480 1024x768 800x600 800x600 800x600 640x480 640x400 640x384 576x384 512x384 400x300 400x300 320x240
    Selected XvImage adaptor with yuyv support: NV Video Overlay on port 65 (grabdisplay)
    Selected XvImage adaptor with yuyv support: NV Video Blitter on port 66 (grabdisplay)
    No XvVideo port available.
    Warning: Cannot convert string "none" to type relief
    ioctl VIDIOC_G_FBUF: Invalid argument
    classical overlay is disabled*** GRABBER DEVICE TYPE = v4l2
    Warning: Missing charsets in String to FontSet conversion
    MMX, SSE, AMD MMX extensions, SSE2, 3DNOW, have been detected.
    Method mmxext_64K
    *** AUDIO DEVICE TYPE = alsa
    *** MIXER DEVICE TYPE = alsa

     
    • you have to install xterm

       
    • xterm is already installed
      Dave

       
    • ok.
      ton pb est surement le meme que celui ci:
      http://forum.ubuntu-fr.org/viewtopic.php?id=98746

      corrigé en 2.4.1cvs1

       
    • do you know of any posts in english or how to convert to english
      thanks dave

       
    • your default shell in Ubuntu is dash.
      sh -> dash
      I suggest you to modify this link:
      sh -> xterm
      and that should work.
      (it's fixed in our last release)

       
    • sorry
      sh -> bash (not sh -> xterm)

       
    • sorry i'm new to linux
      do you mean in a terminal type bash
      and then type xdtv to start the prog
      the schedule  did not work
      thanks for your replys
      Dave

       
      • I mean,
        sh is a link (look into your Ubuntu distrib).
        With ubuntu this link launch the dash shell:

        neox@amd64-full-linux:~$ ls -l /bin/sh
        lrwxrwxrwx 1 root root 4 2007-04-13 22:05 /bin/sh -> dash
        neox@amd64-full-linux:~$ ls -l /bin/dash
        -rwxr-xr-x 1 root root 86088 2007-03-05 07:00 /bin/dash

        xdtv needs the bash shell:

        neox@amd64-full-linux:~$ ls -l /bin/sh
        lrwxrwxrwx 1 root root 4 2007-04-13 22:05 /bin/sh -> bash
        neox@amd64-full-linux:~$ ls -l /bin/bash
        -rwxr-xr-x 1 root root 86088 2007-03-05 07:00 /bin/bash

        so you have to redefine this link: /bin/sh -> bash

        (may be you have to install bash , I don't know, as I don't use this ugly distrib

         
    • what distro do you use?
      in the past i used a distro called kanotix (debian) but it no longer exists

      dave