"accept: Invalid argument" when streaming

  • When I try to stream, I get the error message "accept: Invalid argument" repeating many times in console and I cannot connect to the stream. The recording itself works fine. Strangely, the streaming works just fine from another machine with the same OS, the same XDTV package just different TV card. I would be grateful if somebody had a suggestion what could be wrong - google search did not reveal anything...

    • Oh, so I have solved this one - I had to change the streaming port. Although I did not know about anything using the original port, the firewall was down etc... Anyway, maybe this helps somebody else with the same problem.

    • may be the ip port you choose for xdtv was used by another application...


      • That's the weird thing - it was not. At first I used 4444 which is hardly used by something, and it gave me that error, then I tried 8000 (since I think it is used for streaming), the same error (and none application running on 8000). And after a lot of effort I finally found by accident that 8001 did not give the error and everything works just fine with it. I don't understand it but I am glad it works now. I did not have this problem on other machine which most probably means that it is just a question of network setup (?)
        BTW I really like XDTV, especially the recording and streaming features are great :)

        • yes, your problem should be a network problem: ip or firewall one.
          thanks for your support.