#13 dependencies failuer

closed-accepted
Sir Pingus
None
1
2003-10-05
2003-10-04
Gadi Bergman
No

Hi,

I tried installing your application on my 786 MDK 9.1,
getting a cross dependencies error in the RPM:

rpm -i divx4linux-20030428-1mdk.i586.rpm
error: failed dependencies:
libdivx4linux0 = 20030428-1mdk is needed by
divx4linux-20030428-1mdk

rpm -i libdivx4linux0-20030428-1mdk.i586.rpm
error: failed dependencies:
divx4linux = 20030428-1mdk is needed by
libdivx4linux0-20030428-1mdk

Thanks,
Gadi.

Discussion

  • Sir Pingus
    Sir Pingus
    2003-10-04

    Logged In: YES
    user_id=654886

    you just have to launch this command:

    rpm -Uvh divx4linux-20030428-1mdk.i586.rpm
    libdivx4linux0-20030428-1mdk.i586.rpm

    install the 2 packages in the same command.

    bye Pingus

     
  • Sir Pingus
    Sir Pingus
    2003-10-05

    • priority: 5 --> 1
    • assigned_to: nobody --> pingus77
    • status: open --> closed-accepted
     
  • Logged In: NO

    Thanks, that worked.

    Now I ran into another problem concerning ffmpeg:

    rpm -i ffmpeg-0.4.8-1mdk.i586.rpm
    error: failed dependencies:
    libavcodec.so is needed by ffmpeg-0.4.8-1mdk
    libavformat.so is needed by ffmpeg-0.4.8-1mdk

    I have already managed to compile these files using the
    source code of ffmpeg-0.4.8.

    How should I blend these files in?

    Thanks again,
    Gadi.

     
  • Logged In: NO

    if you already install ffmpeg-0.4.8 (I hope to find
    ffmpeg0.4.8-0.4.8)
    o you can force the installation or:

    rpm -e ffmpeg ffmpeg-devel
    and next :
    rpm -Uvh ffmpeg0.4.8-0.4.8 ffmpeg0.4.8-devel....

    bye Pingus