Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

Java Cybergarage Exception with Ubuntu

Jdogzilla
2007-04-08
2013-05-03
  • Jdogzilla
    Jdogzilla
    2007-04-08

    Hello all, I am now using Ubuntu 6.10 and Java 1.6.
    Upon starting the server, I get the following exceptions when all the files are loaded;

    CyberGarage warning : Operation not permitted
    java.io.IOException: Operation not permitted
            at java.net.PlainDatagramSocketImpl.send(Native Method)
            at java.net.DatagramSocket.send(DatagramSocket.java:612)
            at org.cybergarage.upnp.ssdp.HTTPMUSocket.send(HTTPMUSocket.java:150)
            at org.cybergarage.upnp.ssdp.HTTPMUSocket.post(HTTPMUSocket.java:176)
            at org.cybergarage.upnp.ssdp.SSDPNotifySocket.post(SSDPNotifySocket.java:80)
            at net.sourceforge.x360mediaserve.upnpmediaserver.responder.UPNPListener.byebye(UPNPListener.java:1134)
            at net.sourceforge.x360mediaserve.upnpmediaserver.responder.UPNPListener.byebye(UPNPListener.java:1166)
            at net.sourceforge.x360mediaserve.upnpmediaserver.responder.UPNPListener.stop(UPNPListener.java:1615)
            at net.sourceforge.x360mediaserve.upnpmediaserver.responder.UPNPListener.start(UPNPListener.java:1583)
            at net.sourceforge.x360mediaserve.upnpmediaserver.responder.UPNPResponder.start(UPNPResponder.java:900)
            at net.sourceforge.x360mediaserve.newServlet.MediaServer.setup(MediaServer.java:99)
            at net.sourceforge.x360mediaserve.newServlet.MediaServer.<init>(MediaServer.java:79)
            at Run.main(Run.java:48)

    Any idea why this is happening?

     
    • Unamanic
      Unamanic
      2007-04-08

      Are you starting it with your ip address in the command line "./start 192.168.0.1" (or whatever your ip is(use ifconfig to find this information)).  If you are not, then give it a try.  Also are you using a release or did you compile form CVS?

      Will

       
    • Jdogzilla
      Jdogzilla
      2007-04-08

      Hi Will, thanks for writing.

      I have put my server name in the start file.  I am using the build from the download section ... I did not make my own CVS build.  Any suggestions?  I'm using the latest JVM from Sun - its 1.6.0_01.

      Thanks

       
    • Jdogzilla
      Jdogzilla
      2007-04-08

      OK ... solved my own problem ... I did not have TCP port 7000 open.  Only had UDP on 1900 open.  After putting both in, its working now.