Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

Fix for FLAC playing on LINUX

2006-06-10
2013-05-03
  • I was having trouble playing FLAC files, so I made a modification to the FLACPCM script.  I am not sure what the original intent of the code was, put I changed it to:

    flac -d "$1" -c --endian=big --force-raw-format --sign=signed

    I also tested it on a track that contained a double quote in the full path and it worked fine, specifically, it was "Rock/Phil Collins/12"ers/01-Take Me Home.flac".

     
    • Alex Atkin UK
      Alex Atkin UK
      2006-10-28

      Are you sure about that?  I had to set it to:

      flac -d "$var" -c --endian=big --force-raw-format --sign=signed

      It didnt work the way you suggested.

       
    • perkabalo
      perkabalo
      2007-03-04

      Thanks for the info, but i'm still unable to stream flac files. I modified flacpcm to "flac -d "$var" -c --endian=big --force-raw-format --sign=signed"
      I'm running Ubuntu Edgy, and I noticed that I had to change permissions of the start script to sucessfully run x360mediaserve. First time i tried to play a flac file i got something like acess denied for flacpcm, changed permission of that file too and now i get this message:

      java.io.IOException: Cannot run program "/home/pelle/Desktop/xmediaserve/ScriptDir/flacpcm" (in directory "/home/pelle/Desktop/xmediaserve/ScriptDir"): java.io.IOException: error=2, No such file or directory

      Any help much appreciated!