Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

x264Vfw Bitrate issue

Meghana
2012-06-04
2012-10-08
  • Meghana
    Meghana
    2012-06-04

    I am using x264Vfw encoder with directshow to create Mp4 video which almost
    works fine , but no idea why video is 100-125 kbps bigger than whatever
    bitrate we set for X264Vfw .

    Can anybody have idea on this??

    Thanks

     
  • BugMaster
    BugMaster
    2012-06-05

    First of all it is normal to have small % of deviation (lower or higher) from
    target bitrate. Also make sure that you check bitrate WITHOUT container
    overhead (and WITHOUT audio if you muxed it in).

     
  • Meghana
    Meghana
    2012-06-06

    thanks @masternobody , i check bitare without Audio stream , i have set
    bitrate to 300 kbps , and my video gets bitrate 358 kbps , how do i get bitare
    without container overhead???

     
  • Meghana
    Meghana
    2012-06-13

    i have set bit-rate for x264vfw to 480 kbit/s from registry , now if my frame-
    rate is 15 fps then i get bitrate of my file 380-450 kbit/s where's if i set
    frame rate to 30 then i get bitrate over 700...

     
  • BugMaster
    BugMaster
    2012-06-13

    It probably would be faster and simpler if you upload small 1-2 minutes
    encoded sample with problem to
    http://www.mediafire.com/. You probably
    incorrectly set fps (at muxing stage and not at encoding stage) or calc
    resulted bitrate.