wxMaxima won't connect in Ubuntu 11.10

  • I have just upgraded to Ubuntu 11.10. I used to install wxMaxima from Istvan
    Blahota's ppa:blahota/wxmaxima. With the new OS version, that ppa was
    disabled. wxMaxima 11.04.0 was installed, replacing 11.08. When 11.04.0 is
    started, the message is "Maxima started. Waiting for connection..." Can anyone

  • With the new OS version, that ppa was disabled.

    It is normal. After the upgrade process enable the ppa and install Maxima and
    wxMaxima packages from my repo.

  • Thanks! You have solved my problem once again.

  • I have upgraded to 13.10 on several machines. I had wxMaxima installed, always using Istvan Blahota's ppa. The ppa was disabled upon upgrade. So too, it seems, is wxMaxima. I have uninstalled and reinstalled several times with the ppa's both enabled and disabled. While the command line Maxima is working, wxMaxima does not seem to start. Help, please!

  • I uploaded wxMaxima 13.04.2 packages for Ubuntu 13.10 to my ppa some minutes ago. You can use them immediately. (I did not think that Ubuntu guys failed official packages...)

    • Alejandro V.
      Alejandro V.

      Dear Istvan Blahota,

      I had a problem installing wxMaxima in Ubuntu 12.04.
      I tried several ways of doing it always with the same result.
      Opening wxmaxima gives a white window with a "waiting for
      connection" message below and nothing more happens.
      I tried to install the last version compiling it as it was proposed
      in a web page of yours without success, but may be I made a mistake
      When I run wxmaxima from the terminal the following message repeated:

      (wxmaxima:5741): WARNING : IPP request failed with status 1280

      and the window of wxMaxima is white, with the tips window on top also empty and everthing apparently hanged.

      The same happens if I ran wxMaxima from the menu icon (without any error message in this case except the "connection message).
      I do not know where to find a log file to put here to help.

      This last installation was done from the Ubuntu installation center (wxMaxima version 11.08.0-1 and Maxima 5.24.0-1build1). I thought it would be more stable, but the same thing happen.
      I am using gnome-shell and have Ubuntu 12.04 installed.
      I aldo tried putting your ppa's.

      I think that I am carring a problem from some of my first install attempts
      that went wrong.


      Last edit: Alejandro V. 2014-07-16
      • Dear Alejandro,

        wxMaxima 13.04.2 and Maxima 5.29.1 (both from my ppa) work for me correctly in Ubuntu 12.04.4.

        Sorry, but from your description I do not know what the problem is in your situation.

        • Alejandro V.
          Alejandro V.

          Thank you so much for your reply!
          Previously I added your ppa's with the same results.
          I am going to give it a try again.
          Is there any file where I can find more information?
          Is there a log file wxmaxima writes somewhere at startup?

          Thank you.

        • Alejandro V.
          Alejandro V.

          Dear István,
          I removed completely wxmaxima and maxima using Synaptic. Afterwards, I added your ppa's, and installed maxima 5.29.1 and wxmaxima 13.04.2 (in that order).
          I tested maxima from the terminal and it worked.
          When I run wxmaxima I have the same problem I had before. I forgot to mention before that below the white window of wxmaxima appears a message saying something like "Maxima initiated. Waiting for connection" (it is writen in spanish, I translated it for you).
          What can I do?

          Last edit: Alejandro V. 2014-07-29
          • Alejandro V.
            Alejandro V.

            It seems to be a problem with the wifi, because once I plug the ethernet cable everything works (I followed https://bbs.archlinux.org/viewtopic.php?id=179759)

            • Alejandro V.
              Alejandro V.

              Any help?

  • Istvan, you're a magician and a lifesaver. Thanks so much!!!