wxmaxima doesn't start in Ubuntu 12.04

2014-07-29
2014-08-06
  • Alejandro V.
    Alejandro V.
    2014-07-29

    I am trying to install wxmaxima in my Samsung R440 notebook with Ubuntu 12.04 and gnome-shell.
    After many attempts to install Maxima and wxMaxima I am still getting the following message repeated when I run wxmaxima from the terminal:
    (wxmaxima:5741): WARNING : IPP request failed with status 1280
    and the window of wxMaxima stays white, with the "tips window" on top also empty and everthing apparently frozen.
    The same happens if I run wxMaxima from the menu icon (without any error message in this case).
    I do not know where to find a log file to add here to help.
    This last installation was done from the Ubuntu installation center (wxMaxima version 11.08.0-1 and Maxima 5.24.0-1build1) after removing previous installations.
    I thought it would be more secure.
    Previously I tried to compile the newest version of maxima and wxmaxima following the instructions from István Blahota page.
    I always obtained the same result.
    I googled this but did not find a similar problem anywhere.
    I think I might have done a mistake in some of the previous installations that I cannot undo.
    Please help me.

     
    Last edit: Alejandro V. 2014-07-29
  • Alejandro V.
    Alejandro V.
    2014-08-04

    It seems to be a problem with the wifi, because once I plug the ethernet cable everything works (I followed https://bbs.archlinux.org/viewtopic.php?id=179759).
    Even after the suggested installation in that link I could only run wxmaxima successfully with the ethernet plugued in.

     
  • Alejandro V.
    Alejandro V.
    2014-08-06

    I recently installed Xmaxima and it communicated fine with maxima.

    In case it helps I add the following information of the version of wxWidgets installed: libwxgtk2.8-0 2.8.12.1-6ubuntu2.2
    ( and libwxbase2.8-0 2.8.12.1-6ubuntu2.2 ).

    Any ideas to solve this communcation problem between wxmaxima and maxima will be welcome.

    Thanks.