#2 wxHaskell programs segfault when started, what to do?

v1.0 (example)
closed
nobody
None
5
2013-09-27
2010-04-21
Anonymous
No

wxHaskell programs build just fine. However, when I try to run them, this happens:

20:53:53: Debug: wxColour::Set - couldn't set to colour string 'GREY'
Segmentation fault/access violation in generated code
20:53:53: Debug: wxColour::Set - couldn't set to colour string 'MEDIUM GREY'
20:53:53: Debug: wxColour::Set - couldn't set to colour string 'LIGHT GREY'
20:53:53: Debug: wxColour::Set - couldn't set to colour string 'CYAN'
20:53:53: Debug: wxColour::Set - couldn't set to colour string 'GREY'
20:53:53: Debug: wxColour::Set - couldn't set to colour string 'MEDIUM GREY'

Time stamp and the order in which the segfault is printed can vary.

Running Windows 7 with the haskell platform 2010.1.0.0 installed (GHC v. 6.12.1)
wxWidgets 2.8.10 was built using MinGW32 (GCC 3.4.5) with options specified on the Haskell wiki (shared, monolithic, unicode enabled).

I have been struggling to try to hunt down the cause of this for the past few days and am at a loss.

darcs is impractical at the moment, and I will be reporting an issue related to that in a few moments at the appropriate place. I may try the darcs version later, however.

Discussion


  • Anonymous
    2010-04-21

    Also, since I forgot to mention it, I am running the 64 bit version of windows.

     
  • As this is an old support request, I suppose this ticket can be closed. When this problem still exists, please enter a bug ticket with a sample program.

     
    • status: open --> closed
    • Group: --> v1.0 (example)