I have the same problem as these two.  I am running ubuntu 8.10.  To answer Mads Lindstrom's question, ubuntu says I have version 2.13.4-0ubuntu1 of libgtk2.0 and libgtk2.0-dev.  I also have libgtk1.2 installed (though not the dev files).

I have been able to successfully run this hello world tutorial program from the wxwidgets website:

http://www.wxwidgets.org/docs/tutorials/hworld.txt

So, I think the problem is not with wxwidgets itself.

--Chris Casinghino
 
I am having the same problem (see my earlier e-mails on the list) on Ubuntu
with both wxGTK 2.8.9 and 2.8.7. Unfortunately noone has replied to my
previous e-mail yet.

On Saturday 10 January 2009 21:53:14 Kellen J. McClain wrote:
> I'm running Fedora 10, and installed wxGTK with "yum", (version 2.8.9),
> and have successfully compiled wxhaskell-0.11.0 (using --with-opengl
> --with-contrib --with-mediactrl --wx-toolkit=gtk2), but whenever I run
> any of the sample programs, no windows pop up, and the same error
> occurs:
>
> (process:16395): GLib-GObject-CRITICAL **: gtype.c:2458: initialization
> assertion failed, use IA__g_type_init() prior to this function
>
> (process:16395): GLib-CRITICAL **: g_once_init_leave: assertion
> `initialization_value != 0' failed
>
> (process:16395): Gdk-CRITICAL **: gdk_cursor_new_for_display: assertion
> `GDK_IS_DISPLAY (display)' failed
>
> I tried running a sample program written in C++ and it ran fine, so I'm
> thinking that it is a problem with something in wxhaskell. I noticed
> that Jose Ramirez in 2008-08-12 came across the same problem
> (http://sourceforge.net/mailarchive/message.php?msg_name=89c11d70808120559j
>63465383r1c61f4c11a46d47c%40mail.gmail.com). Did anyone figure out what the
> problem was?