I've done yet another attempt at installing wxHaskell on Mac OS X (Intel, Snow Leopard)
following the page at 

 http://www.haskell.org/haskellwiki/WxHaskell/MacOS_X

I setup ghc 7.0.4
I did brew install wxmac --devel

I am then asked to check my path to make sure I am using  "my" wxWidgets and not the default one

(I had deleted an old reference to wx 2.8 - now my path does not mention wxwidgets at all)

wx2.9.3 was installed by homebrew in /opt/local/.... but I had no idea what to put in my path
(A question to stackoverflow got a completely useless answer....)

So I decided to soldier on...
  I did   cabal install wx cabal-macosx   --- waited - all installed just fine - it seemed
to have picked up all the stuff installed by brew.

I then got the EnableGUI module as described lower down the page
it compiled fine
I then edited HelloWord.hs to import it
,and then started ghci as recommended

I get the error

Loading package wxc-0.90.0.2 ... can't load .so/.DLL for: wx_baseu-2.9 (dlopen(/opt/local/lib/libwx_baseu-2.9.dylib, 9): no suitable image found.  Did find:
/opt/local/lib/libwx_baseu-2.9.dylib: mach-o, but wrong architecture)


How do I fix this?

--------------------------------------------------------------------
Andrew Butterfield     Tel: +353-1-896-2517     Fax: +353-1-677-2204
Lero@TCD, Head of Foundations & Methods Research Group
Director of Teaching and Learning - Undergraduate,
School of Computer Science and Statistics,
Room G.39, O'Reilly Institute, Trinity College, University of Dublin
                          http://www.scss.tcd.ie/Andrew.Butterfield/
--------------------------------------------------------------------