On 28 July 2011 02:45, Dave Tapley <dukedave@gmail.com> wrote:
Please find attached a darcs patch file with the changes I had to make to build wxcore.
Feel free to have a look and comment, they are all very much "make it compile" changes and I suspect I may have introduced badness (returning a null pointer).

Unfortunately having made these changes and following these steps¹ I am now getting this error, which is a little confusing:

wxhaskell-dev/wx$ sudo cabal install --global
Resolving dependencies...
cabal: dependencies conflict: wxcore-0.13.1 requires containers ==0.4.0.0
however
containers-0.4.0.0 was excluded because wxcore-0.13.1 requires containers
==0.3.0.0

Its other dependencies have installed correctly:
wxhaskell-dev/wx$ ghc-pkg list wxdirect
/var/lib/ghc-6.12.1/package.conf.d
   wxdirect-0.13.1

wxhaskell-dev/wx$ ghc-pkg list wxcore
/var/lib/ghc-6.12.1/package.conf.d
   wxcore-0.13.1


Any idea what this could mean?

Dave,

¹ http://haskell.org/haskellwiki/WxHaskell/Building#Source_Release


Hmm, further to this:

$ darcs pull
Pulling from "http://code.haskell.org/wxhaskell"...
Official wxHaskell darcs repository
**********************
No remote changes to pull in!
$ cd wx
$ cabal configure
Resolving dependencies...
Configuring wx-0.13.1...
Warning: This package indirectly depends on multiple versions of the same
package. This is highly likely to cause a compile failure.
package wxcore-0.13.1 requires containers-0.3.0.0
package wxdirect-0.13.1 requires containers-0.4.0.0
package wxcore-0.13.1 requires parsec-2.1.0.1
package wxdirect-0.13.1 requires parsec-3.1.1