So, does that work?


On 17 July 2011 06:16, Eric Y. Kow <eric.kow@gmail.com> wrote:
On Sun, Jul 17, 2011 at 10:57:55 +0100, Eric Y. Kow wrote:
> On Sun, Jul 17, 2011 at 10:18:53 +0100, Eric Y. Kow wrote:
> > 3. wxHaskell builds fine, but when running any GUI app:
> >    The procedure entry point __gxx_personality_v0 could not be
> >    located in the dynamic link library libstdc++-6.dll
>
> Oh, that's odd.  I just noticed that I can run my program fine
> from the MSYS shell, but if I run it from the DOS prompt or by
> double-clicking I get error message above.

OK, sorry for being noisy.  What worked for me is to uninstall
the TDM GCC I had installed earlier and to make sure that
MinGW/bin was in my PATH.

I think the active ingredient in these steps is making sure we're using
the mingw libstdc++ and not the tdm one.

This makes me think that maybe my self-built wxWidgets might have worked
(although I think I *was* working from the MSYS shell then) if I had
done the same.  After all, the wxPack version was built with the same.

--
Eric Kow <http://erickow.com>

------------------------------------------------------------------------------
AppSumo Presents a FREE Video for the SourceForge Community by Eric
Ries, the creator of the Lean Startup Methodology on "Lean Startup
Secrets Revealed." This video shows you how to validate your ideas,
optimize your ideas and identify your business strategy.
http://p.sf.net/sfu/appsumosfdev2dev
_______________________________________________
wxhaskell-users mailing list
wxhaskell-users@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/wxhaskell-users