>- using debug-wx to see what stage things go wrong at? https://github.com/kowey/debug-wx
(it's a collection of hello worlds for different layers)

Very helpful , thanks. Steps1 ok. Step 2 break

mbp2-de-luc:debug-wx luc$ wx-config

 wx-config [--prefix[=DIR]] [--exec-prefix[=DIR]] [--release] [--version-full]
           [--list] [--selected-config] [--host=HOST] [--toolkit=TOOLKIT]
           [--universal[=yes|no]] [--unicode[=yes|no]] [--static[=yes|no]]
           [--debug[=yes|no]] [--version[=VERSION]] [--basename] [--cc] [--cxx]
           [--cppflags [base]] [--cxxflags [base]] [--cflags]
           [--rescomp] [--linkdeps] [--ld] [--utility=UTIL]
           [--libs [LIBS...]] [--optional-libs [LIBS...]]

    wx-config returns information about the wxWidgets libraries available on
  your system.  It may be used to retrieve the information required to build
  applications using these libraries using --cppflags, --cxxflags, --cflags,
  and --libs options. And you may query the properties of this configuration
  using --query-{host,toolkit,widgetset,chartype,debugtype,version,linkage}.

    NOTE:    Usage of --debug and --query-debugtype are only relevant if you
  have any  versions prior to 2.9 installed  and use the --version option to
  select an earlier version.

    If multiple builds of wxWidgets  are available,  you can use the options
  --prefix, --host, --toolkit, --unicode, --static, --universal or --version
  to select from them.  The  --selected-config  option shows the name of the
  current configuration and --list  shows available alternatives which match
  specified criteria.  The  --utility  option returns the correct version of
  UTIL to use with the selected build.  The  --linkdeps  option returns only
  static libraries for your makefile link rule dependencies.

    The LIBS arguments (comma or space separated) may be used to specify the
  wxWidgets libraries that  you wish to use. The "std" label may be used  to
  import all libraries that would be used by default if none were  specified
  explicitly, e.g. wx-config --libs core,base. The "all" label may  be  used
  to  import  all libraries that have been compiled which are shown  in  the
  list  below.  The  --optional-libs parameter should be followed by  a list
  of  libs that should be linked to, but only if they are available.

  Available libraries in this build are:
  xrc webview stc richtext ribbon propgrid aui gl html qa adv core xml net base

mbp2-de-luc:debug-wx luc$ cd wxWidgets
mbp2-de-luc:wxWidgets luc$ g++ minimal.cpp `wx-config --libs --cflags` -o minimal
mbp2-de-luc:wxWidgets luc$ ./minimal 

Step 2:

mbp2-de-luc:wxWidgets luc$ cd ..
mbp2-de-luc:debug-wx luc$ cd wxcore
mbp2-de-luc:wxcore luc$ ghc --make HelloWorld
[1 of 1] Compiling Main             ( HelloWorld.hs, HelloWorld.o )
Linking HelloWorld ...
ld: warning: ignoring file /usr/local/lib/libwx_osx_cocoau_xrc-2.9.dylib, file was built for unsupported file format ( 0xcf 0xfa 0xed 0xfe 0x 7 0x 0 0x 0 0x 1 0x 3 0x 0 0x 0 0x 0 0x 6 0x 0 0x 0 0x 0 ) which is not the architecture being linked (i386): /usr/local/lib/libwx_osx_cocoau_xrc-2.9.dylib
ld: warning: ignoring file /usr/local/lib/libwx_osx_cocoau_webview-2.9.dylib, file was built for unsupported file format ( 0xcf 0xfa 0xed 0xfe 0x 7 0x 0 0x 0 0x 1 0x 3 0x 0 0x 0 0x 0 0x 6 0x 0 0x 0 0x 0 ) which is not the architecture being linked (i386): /usr/local/lib/libwx_osx_cocoau_webview-2.9.dylib
ld: warning: ignoring file /usr/local/lib/libwx_osx_cocoau_stc-2.9.dylib, file was built for unsupported file format ( 0xcf 0xfa 0xed 0xfe 0x 7 0x 0 0x 0 0x 1 0x 3 0x 0 0x 0 0x 0 0x 6 0x 0 0x 0 0x 0 ) which is not the architecture being linked (i386): /usr/local/lib/libwx_osx_cocoau_stc-2.9.dylib
ld: warning: ignoring file /usr/local/lib/libwx_osx_cocoau_richtext-2.9.dylib, file was built for unsupported file format ( 0xcf 0xfa 0xed 0xfe 0x 7 0x 0 0x 0 0x 1 0x 3 0x 0 0x 0 0x 0 0x 6 0x 0 0x 0 0x 0 ) which is not the architecture being linked (i386): /usr/local/lib/libwx_osx_cocoau_richtext-2.9.dylib
ld: warning: ignoring file /usr/local/lib/libwx_osx_cocoau_ribbon-2.9.dylib, file was built for unsupported file format ( 0xcf 0xfa 0xed 0xfe 0x 7 0x 0 0x 0 0x 1 0x 3 0x 0 0x 0 0x 0 0x 6 0x 0 0x 0 0x 0 ) which is not the architecture being linked (i386): /usr/local/lib/libwx_osx_cocoau_ribbon-2.9.dylib
ld: warning: ignoring file /usr/local/lib/libwx_osx_cocoau_propgrid-2.9.dylib, file was built for unsupported file format ( 0xcf 0xfa 0xed 0xfe 0x 7 0x 0 0x 0 0x 1 0x 3 0x 0 0x 0 0x 0 0x 6 0x 0 0x 0 0x 0 ) which is not the architecture being linked (i386): /usr/local/lib/libwx_osx_cocoau_propgrid-2.9.dylib
ld: warning: ignoring file /usr/local/lib/libwx_osx_cocoau_aui-2.9.dylib, file was built for unsupported file format ( 0xcf 0xfa 0xed 0xfe 0x 7 0x 0 0x 0 0x 1 0x 3 0x 0 0x 0 0x 0 0x 6 0x 0 0x 0 0x 0 ) which is not the architecture being linked (i386): /usr/local/lib/libwx_osx_cocoau_aui-2.9.dylib
ld: warning: ignoring file /usr/local/lib/libwx_osx_cocoau_gl-2.9.dylib, file was built for unsupported file format ( 0xcf 0xfa 0xed 0xfe 0x 7 0x 0 0x 0 0x 1 0x 3 0x 0 0x 0 0x 0 0x 6 0x 0 0x 0 0x 0 ) which is not the architecture being linked (i386): /usr/local/lib/libwx_osx_cocoau_gl-2.9.dylib
ld: warning: ignoring file /usr/local/lib/libwx_osx_cocoau_html-2.9.dylib, file was built for unsupported file format ( 0xcf 0xfa 0xed 0xfe 0x 7 0x 0 0x 0 0x 1 0x 3 0x 0 0x 0 0x 0 0x 6 0x 0 0x 0 0x 0 ) which is not the architecture being linked (i386): /usr/local/lib/libwx_osx_cocoau_html-2.9.dylib
ld: warning: ignoring file /usr/local/lib/libwx_osx_cocoau_qa-2.9.dylib, file was built for unsupported file format ( 0xcf 0xfa 0xed 0xfe 0x 7 0x 0 0x 0 0x 1 0x 3 0x 0 0x 0 0x 0 0x 6 0x 0 0x 0 0x 0 ) which is not the architecture being linked (i386): /usr/local/lib/libwx_osx_cocoau_qa-2.9.dylib
ld: warning: ignoring file /usr/local/lib/libwx_osx_cocoau_adv-2.9.dylib, file was built for unsupported file format ( 0xcf 0xfa 0xed 0xfe 0x 7 0x 0 0x 0 0x 1 0x 3 0x 0 0x 0 0x 0 0x 6 0x 0 0x 0 0x 0 ) which is not the architecture being linked (i386): /usr/local/lib/libwx_osx_cocoau_adv-2.9.dylib
ld: warning: ignoring file /usr/local/lib/libwx_osx_cocoau_core-2.9.dylib, file was built for unsupported file format ( 0xcf 0xfa 0xed 0xfe 0x 7 0x 0 0x 0 0x 1 0x 3 0x 0 0x 0 0x 0 0x 6 0x 0 0x 0 0x 0 ) which is not the architecture being linked (i386): /usr/local/lib/libwx_osx_cocoau_core-2.9.dylib
ld: warning: ignoring file /usr/local/lib/libwx_baseu_xml-2.9.dylib, file was built for unsupported file format ( 0xcf 0xfa 0xed 0xfe 0x 7 0x 0 0x 0 0x 1 0x 3 0x 0 0x 0 0x 0 0x 6 0x 0 0x 0 0x 0 ) which is not the architecture being linked (i386): /usr/local/lib/libwx_baseu_xml-2.9.dylib
ld: warning: ignoring file /usr/local/lib/libwx_baseu_net-2.9.dylib, file was built for unsupported file format ( 0xcf 0xfa 0xed 0xfe 0x 7 0x 0 0x 0 0x 1 0x 3 0x 0 0x 0 0x 0 0x 6 0x 0 0x 0 0x 0 ) which is not the architecture being linked (i386): /usr/local/lib/libwx_baseu_net-2.9.dylib
ld: warning: ignoring file /usr/local/lib/libwx_baseu-2.9.dylib, file was built for unsupported file format ( 0xcf 0xfa 0xed 0xfe 0x 7 0x 0 0x 0 0x 1 0x 3 0x 0 0x 0 0x 0 0x 6 0x 0 0x 0 0x 0 ) which is not the architecture being linked (i386): /usr/local/lib/libwx_baseu-2.9.dylib
mbp2-de-luc:wxcore luc$ ./HelloWorld 
dyld: Symbol not found: __ZN10wxDateTime13TIME_T_FACTORE
  Referenced from: /Users/luc/.cabal/lib/wxc-0.90.0.4/ghc-7.4.2/libwxc.dylib
  Expected in: flat namespace
 in /Users/luc/.cabal/lib/wxc-0.90.0.4/ghc-7.4.2/libwxc.dylib
Trace/BPT trap: 5
mbp2-de-luc:wxcore luc$ 

--------------
Luc
be.linkedin.com/in/luctaesch/
Envoyé avec Sparrow

Le mardi 19 mars 2013 à 15:38, Eric Kow a écrit :

Do any of the following help?

- making sure you have a 64bit wxWidgets
- using debug-wx to see what stage things go wrong at? https://github.com/kowey/debug-wx
(it's a collection of hello worlds for different layers)
- using my cabal-macosx branch? https://github.com/kowey/cabal-macosx

I might have forgotten to do a release, in which case sorry.

I'm on Lion, using ghc 7.4.1, wxWidgets from the Homebrew installer


On 19 Mar 2013, at 00:01, luc taesch wrote:

Are there any setup to do after install , (the equivalent of LD_CONFIG ?)

what i did , following [0 ]

1/ install wxwigets went fine

2/ but I cannot get a helllo world example running .
the cabal-macosx does not seems to be seen ( what
is expected in fact ?). any setup ?


3/ trying and run the sample by hand raise an Error

Anyway this is much farther I ever been on a haskell gui install on the mac.
but not good enough so far.
I would love trying reactive banana.

ar there any positive experience of installing wx on 10.8
( according to [0], yes) ?
any tricks to know ?


details here : http://hpaste.org/84285 due to size limitations.



------------------------------------------------------------------------------
Everyone hates slow websites. So do we.
Make your web apps faster with AppDynamics
Download AppDynamics Lite for free today:
_______________________________________________
wxhaskell-users mailing list

--
Eric Kow <http://erickow.com>