Hi Dan,
 
I have confirmed the problem exists, but it's really a Haskell Platform (rather than Windows 7)issue - the latest Haskell Platform doesn't include C++ support. Workaround is to use the previous Haskell Platform version. I'm posting to Haskell list to see if there's a work-around.
 
Regards
Jeremy
 
On Mon, 03 May 2010 00:41 -0400, "Dan Haraj" <devharaj@gmail.com> wrote:
I have been trying to build the latest version on windows 7 for a few days now. I have not managed to get it. The furthest I have gotten has given me an error-dump from cabal about /include/wx/string.h after [22 of 22]... \WXCore.o
 
I built wx in the way that was prescribed by the wiki page. I then set the environment variable WXWIN and WXCFG properly. When I tried to run cabal install wx, it failed telling me I didn't have a long list of C libraries. I then ran cabal install wx --extra-include-dirs = "" --extra-lib-dirs "" to point to the libraries in my mingw distribution. I am using my own instead of the one that comes with the haskell platform because the latter didn't seem to have the libraries. I don't know. I am very new to Haskell.
 
Anyway, running with the extra flags worked except for the error I described in the first line of this message. I don't know what to do. I have noticed that wxhaskell's wiki page does not state that it has been successfully built on Win7. Is this the state of things?
 
Thanks
 
-Dan
------------------------------------------------------------------------------

_______________________________________________
wxhaskell-users mailing list
wxhaskell-users@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/wxhaskell-users

-- 
  Jeremy O'Donoghue
  jeremy.odonoghue@gmail.com