When I run either
$ cabal install 'wx < 0.9'
$ cabal install wx-0.13.2.1
cabal fails while trying to build wxcore 0.9.x (sorry I don't have the exact error message anymore).
I'm running Ubuntu 12.04.1 and followed http://www.haskell.org/haskellwiki/WxHaskell/Linux
(so libwxgtk2.8-dev is installed).
One would expect cabal to try to build wxcore of some version 0.13.x or 0.12.x.
It turns out that in the cabal file for wx-0.13.2.1, the constraint for wx-core is '>= 0.12.1.6' in the normal case, and '>=0.13.1' if the splitBase flag is set.
I edited the cabal file appending ''&& < 0.90' to both constraints. Then 'cabal install' worked.