Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

#12 wvHtml produces garbage?

closed
nobody
None
5
2006-03-11
2001-05-07
jim warren
No

I'm sure i've missed something very basic, but i
config'd, "make"'d , and installed 0.6.4 on redhat 7,
and when i converted a word8 doc, the html file that
it produced shows only a page of what i can best
describe as "little boxes"... the html source starts
out like this:<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML
4.0 Transitional//EN" "http://www.w3.org
/TR/REC-html40/loose.dtd">
<html>
<head>
<META HTTP-EQUIV="Content-Type" CONTENT="text/html;
charset=UTF-8">
<META NAME="GENERATOR" CONTENT="wvWare/wvWare version
0.6.3">
<title>
фи<80>ц<84><80>ч<8C><80>ц╝<80>ц╕<80>т<80><80>х<9C><80>ц
<84><80>ч<88><80>ч<88>
<80>ц<94><80>ц╕<80>т<80><80>
</title>
</head>
<body bgcolor="#FFFFFF" text="#000000" link="#0000ee"
vlink="#551a8b">

<!--Section Begins--><br>

<p><div align="left" style=" padding: 0.00mm 0.00mm
0.00mm 0.00mm; "> <p style=
"text-indent: 0.00mm; text-align: left; line-height:
8.333333mm; color: Black; b
ackground-color: White; ">
фи<80>ц<84><80>ч<8C><80>ц╝<80>ц╕<80>т<80><80>х<9C><80>ц
<84><80>ч<88><80>ч<88>
<80>ц<94><80>ц╕<80>т<80><80><!DOCTYPE HTML PUBLIC "-
//W3C//DTD HTML 4.0
Transitional//EN" "http://www.w3.org
/TR/REC-html40/loose.dtd">
<html>
<head>
<META HTTP-EQUIV="Content-Type" CONTENT="text/html;
charset=UTF-8">
<META NAME="GENERATOR" CONTENT="wvWare/wvWare version
0.6.3">
<title>
фи<80>ц<84><80>ч<8C><80>ц╝<80>ц╕<80>т<80><80>х<9C><80>ц
<84><80>ч<88><80>ч<88>
<80>ц<94><80>ц╕<80>т<80><80>
</title>
</head>
<body bgcolor="#FFFFFF" text="#000000" link="#0000ee"
vlink="#551a8b">

<!--Section Begins--><br>

<p><div align="left" style=" padding: 0.00mm 0.00mm
0.00mm 0.00mm; "> <p style=
"text-indent: 0.00mm; text-align: left; line-height:
8.333333mm; color: Black; b
ackground-color: White; ">
фи<80>ц<84><80>ч<8C><80>ц╝<80>ц╕<80>т<80><80>х<9C><80>ц
<84><80>ч<88><80>ч<88>
<80>ц<94><80>ц╕<80>т<80><80>

is there something i need to configure before i can
successfully translate files?

thanks for any pointers!

jim

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0
Transitional//EN" "http://www.w3.org
/TR/REC-html40/loose.dtd">
<html>
<head>
<META HTTP-EQUIV="Content-Type" CONTENT="text/html;
charset=UTF-8">
<META NAME="GENERATOR" CONTENT="wvWare/wvWare version
0.6.3">
<title>
фи<80>ц<84><80>ч<8C><80>ц╝<80>ц╕<80>т<80><80>х<9C><80>ц
<84><80>ч<88><80>ч<88>
<80>ц<94><80>ц╕<80>т<80><80>
</title>
</head>
<body bgcolor="#FFFFFF" text="#000000" link="#0000ee"
vlink="#551a8b">

<!--Section Begins--><br>

<p><div align="left" style=" padding: 0.00mm 0.00mm
0.00mm 0.00mm; "> <p style=
"text-indent: 0.00mm; text-align: left; line-height:
8.333333mm; color: Black; b
ackground-color: White; ">
фи<80>ц<84><80>ч<8C><80>ц╝<80>ц╕<80>т<80><80>х<9C><80>ц
<84><80>ч<88><80>ч<88>
<80>ц<94><80>ц╕<80>т<80><80>

Discussion

  • jim warren
    jim warren
    2001-05-07

    Logged In: YES
    user_id=213366

    additional: i tried to convert another .doc file... very
    simple, no images, no tables, ... and got this output:

    wvError: (./text.c:400) iconv failed errno: 84, to:iso-8859-
    15 from:UCS-2
    wvError: (./text.c:400) iconv failed errno: 84, to:iso-
    8859-15 from:UCS-2
    wvError: (./text.c:400) iconv failed errno: 84, to:iso-
    8859-15 from:UCS-2
    wvError: (./text.c:400) iconv failed errno: 84, to:iso-
    8859-15 from:UCS-2
    wvError: (./text.c:400) iconv failed errno: 84, to:iso-
    8859-15 from:UCS-2
    wvError: (./text.c:400) iconv failed errno: 84, to:iso-
    8859-15 from:UCS-2
    wvError: (./text.c:400) iconv failed errno: 84, to:iso-
    8859-15 from:UCS-2
    wvError: (./text.c:400) iconv failed errno: 84, to:iso-
    8859-15 from:UCS-2
    wvError: (./text.c:400) iconv failed errno: 84, to:iso-
    8859-15 from:UCS-2
    wvError: (./text.c:400) iconv failed errno: 84, to:iso-
    8859-15 from:UCS-2
    wvError: (./text.c:400) iconv failed errno: 84, to:iso-
    8859-15 from:UCS-2
    wvError: (./text.c:400) iconv failed errno: 84, to:iso-
    8859-15 from:UCS-2

     
  • Logged In: NO

    Hi,

    I'm having the same problem with rh7.1 both with the rpm
    included in the distrib an compiling the source, the same
    config works fine in 6.2.

    Compiling in 7.1 workstation installation gives a lot of
    warnings:

    /usr/include/glib-1.2/glib.h:1308:23: warning: ISO C does
    not permit named variadic macros

    I don't know how to fix this

    Juan Manuel Calvo

     
  • Logged In: NO

    I seem to have detected this feature as well: Using wvHtml
    (on AIX) on a Word 2000 doc I get questionmarks in stead of
    the actual readable text. The html layout code looks fine on
    the other hand.

     
  • Logged In: NO

    On IRIX6.5 I solved this problem by comiling with gcc 2.95.2
    rather than the native cc. Getting question marks rather
    then non-printables seemed to occur with an old libiconv
    which didn't have WIN1252 (or whatever).

     
  • Logged In: NO

    LS,

    This is een iconv problem. Adding "debug" to the source, will show u that
    your iconv is not able to translate from one character set to another. The
    trik here is to find out the source, intermediate and destination set and
    make sure iconv/uconv can find them. (On AIX there's a man page on
    iconv related stuff)

     
  • Dom Lachowicz
    Dom Lachowicz
    2006-03-11

    Logged In: YES
    user_id=69417

    wvHtml is deprecated in favor of "AbiWord --to=html". Thanks.

     
  • Dom Lachowicz
    Dom Lachowicz
    2006-03-11

    • status: open --> closed