Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

#25 Error on launch of wput on AIX

open
nobody
None
5
2011-09-21
2011-09-21
Tom Teal
No

One of our programmers here requested I install wput on an AIX 5.3 System. All of the pre-req\'s to wput installed fine as well as the wput rpm
installed without a problem. When I try and run just the wput -V I get an error. Here are some of the details:

- AIX 5.3 TL Level = 5300-12-04
- Openssl version 0.9.8k
- All pre-req\'s required for wput installed fine
- wput installed fine (wput-0.6.1-3.aix5.1.ppc.rpm)

root:/ ->wput -V
exec(): 0509-036 Cannot load program wput because of the following errors:
0509-130 Symbol resolution failed for /usr/lib/libgnutls-openssl.a(libgnutls-openssl.so.26) because:
0509-136 Symbol _gnutls_rnd (number 27) is not exported from dependent module /usr/lib/libgnutls.a(libgnutls.so.26).
0509-026 System error: Error 0
0509-192 Examine .loader section symbols with the \'dump -Tv\' command.

I looked in the /usr/lib directory and it does have links to several libgnutls* files:
root:/usr/lib ->ls -l libgnu*
lrwxrwxrwx 1 root system 40 Sep 20 11:34 libgnutls-extra.a -> ../../opt/freeware/lib/libgnutls-extra.a
lrwxrwxrwx 1 root system 41 Sep 20 11:35 libgnutls-extra.la -> ../../opt/freeware/lib/libgnutls-extra.la
lrwxrwxrwx 1 root system 42 Sep 20 11:34 libgnutls-openssl.a -> ../../opt/freeware/lib/libgnutls-openssl.a
lrwxrwxrwx 1 root system 43 Sep 20 11:35 libgnutls-openssl.la -> ../../opt/freeware/lib/libgnutls-openssl.la
lrwxrwxrwx 1 root system 34 Sep 20 11:34 libgnutls.a -> ../../opt/freeware/lib/libgnutls.a
lrwxrwxrwx 1 root system 35 Sep 20 11:35 libgnutls.la -> ../../opt/freeware/lib/libgnutls.la

Tried to google for some help and a lot of hits referenced the \"LIBPATH\" environment variable. I check that and first in directory order is /usr/lib:
root:/ ->echo $LIBPATH
/usr/lib:/usr/lib/cobol/coblib::/usr/oracle817/jdbc/lib

Any help would be greatly appreciated.

Tom

Discussion

  • Rumpeltux
    Rumpeltux
    2011-09-21

    Sorry, I have no exact idea what’s wrong there. Probably a version
    mismatch. You can try to compile the binary manually. Wput can also be
    compiled with TLS-support entirely disabled.

     
  • Rumpeltux
    Rumpeltux
    2011-09-21

    • milestone: 789845 -->
     
  • John Ford
    John Ford
    2013-02-09

    I experienced this problem with gnutls 2.12 but not with gnutls 2.10. YMMV