The BackwardR I Go, The Better It Works

I.g.
2012-01-28
2013-05-28
  • I.g.
    I.g.
    2012-01-28

    OK, so I tried to follow idea of catchy title. I don't know if this is the right place for posting this problem so will gladly accept guidance. Finally got WP on MS SQL working. However, I consistently get an HTTP Error 500.0 with the specifc …\php\php-cog.exe-The FastCGI process exited unexpectedly. Physical path is …\wp-slqdbr\index.php which is ironic as that file claims to be a do nothing! The intriguing part is I can simply click on the back arrow in the browser, then the forward arrow, and viola all is well…but only for a given "menu pick". That is, say I've "fixed" Home. Same problem with I hit Sample Page. Applying "fix" of back/forward arrow in the browser and Sample Page works just fine. I am using install at inetpug/wwwroot application Default Web Site. Any help in solving this greatly appreciated as I am very reluctant to take the next step of going to a hosting site without the confidence this install is full working.

     
  • Runner73
    Runner73
    2012-01-28

    Do you try to  use this procedure to intall your ambient?

    Procedure applies to windows 7 64 bit / windows 2008 R2 machines

    IIS + PHP Configuration
    Open web platform installer (if not already installed you can download it from http://www.microsoft.com/download/en/details.aspx?id=6164)
    In the lower right corner, select options and choose how to use IIS web server (no IIS express)
    In the top right search for prola "php", from the results proposed to add the following entries:
    -php 5.3 x
    -php for iis management
    -microsoft sql driver for php 2.0 v v 5.3
    -windows cache extension
    Install any dependencies proposals

    Reboot the machine

    Configuring SQL Server 2008 R2 express edition

    Go on download.microsoft.com
    Search for "sql server 2008 r2 advanced"
    Download the "Microsoft SQL Server2008 R2 RTM-Express with Advanced Services"
    To install with default parameters
    After launching SQL Service configuration manager:
    -enable under "SQL Network Configuration" TCP
    -Double click on the Protocol and under the Ip Address tab
    delete all entries from the TCP Ports and TCP ports Dynamics
    set in the ip section all the ip address tab, TCP Port 1433 to value
    This allows you to connect to DBMS via tcp: IPAddress string .1433

    At this point we must launch a section of windows update on the machine to install the SP1 release of SQL Server, or download it from the site
    download.microsoft.com using as a lookup key always "sql server 2008 r2 advanced"

    After restarting the machine will be properly installed and working IIS + PHP + SQl Server 2008 R2
    In particular, from the IIS control panel you can edit the individual settings of php without going to edit the php.ini file
    N.B.
    Natural choice directory-to develop the website to enable read/write the IUSR user
    -The suggested Protocol for communicating with sql server is php pdo_sqlsrv
    -Waiting for version 1.2 If you encounter strange errors to patch the windows cache extension (http://forums.iis.net/t/1176918.aspx)

    Now to install wordpress use this link:
    http://wordpress.org/extend/plugins/wordpress-database-abstraction/
    http://wordpress.visitmix.com/getting-started