Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

Not all networks are displayed

2006-06-04
2013-04-17
  • The network I want to connect to (ad-hoc), along with others aren't displayed in the wlassistant.
    But when I use the "iwlist eth2 scanning" command, all the networks are listed?

    How can I display my network in het assistant? And will i be able to connect to a WinXP pc, who is sharing the Inet connection?

     
    • Pawel Nawrocki
      Pawel Nawrocki
      2006-06-04

      Hi. AdHoc networks support was a bit broken therefore was disabled. I plan on re-enabling it in the next release, scheduled for sometime after I'm done with finals.

       
    • But there are other networks who aren't displayed as well. These networks are regular managed networks.
      In winXP i do not see anyting special about these network (as in WPA/Special WEP keys/...).
      Is there any way to make these appear in wlanassistant?

      I have read something about enable DHCP in users/groups, but I haven't been able to find the option.

       
      • Pawel Nawrocki
        Pawel Nawrocki
        2006-06-04

        do they appear if you type "iwlist <interface> scan" in console?

         
    • Yes they do!
      That is why i wanted to know.
      BTW:I use the newest Kubuntu edition (dapper drake)

       
      • Pawel Nawrocki
        Pawel Nawrocki
        2006-06-04

        Looks like a parsing problem. Could you send me a sample <iwlist scan> output, incl. a network that does not show up in wlassistant? which version of wireless-tools are you using?

         
    • I will provide as soon as possible an outpout. The version is 5.5, it is combined with Kubuntu (dapper drake)

       
    • sudo eth0 scan

      eth1      Scan completed :
                Cell 01 - Address: 02:15:00:03:40:86
                          ESSID:"ADHOC"
                          Protocol:IEEE 802.11bg
                          Mode:Ad-Hoc
                          Channel:11
                          Encryption key:on
                          Bit Rates:54 Mb/s
                          Extra: Rates (Mb/s): 1 2 5.5 6 9 11 12 18 24 36 48 54
                          Quality=96/100  Signal level=-29 dBm
                          Extra: Last beacon: 62ms ago
                Cell 02 - Address: 00:A0:C5:98:44:6F
                          ESSID:"Default"
                          Protocol:IEEE 802.11b
                          Mode:Master
                          Channel:6
                          Encryption key:on
                          Bit Rates:11 Mb/s
                          Extra: Rates (Mb/s): 1 2 5.5 11
                          Quality=46/100  Signal level=-73 dBm
                          Extra: Last beacon: 181ms ago
                Cell 03 - Address: 00:01:38:61:C3:A6
                          ESSID:"alais"
                          Protocol:IEEE 802.11bg
                          Mode:Master
                          Channel:5
                          Encryption key:on
                          Bit Rates:54 Mb/s
                          Extra: Rates (Mb/s): 1 2 5.5 6 9 11 12 18 24 36 48 54
                          Quality=51/100  Signal level=-70 dBm
                          IE: WPA Version 1
                              Group Cipher : TKIP
                              Pairwise Ciphers (1) : TKIP
                              Authentication Suites (1) : PSK
                          IE: IEEE 802.11i/WPA2 Version 1
                              Group Cipher : TKIP
                              Pairwise Ciphers (1) : CCMP
                              Authentication Suites (1) : PSK
                             Preauthentication Supported
                          Extra: Last beacon: 167ms ago

      Output from wifimanager:
      [img]http://users.pandora.be/vanthijs/Kubuntu/wifimanager.png[/img]

       
      • Pawel Nawrocki
        Pawel Nawrocki
        2006-06-05

        Hi. Well... on the screenshot all non-adhoc networks that are in the console output ARE shown (even more;), so...
        Could you include 'iwlist <xxx> scan' console output that includes a network that wlassistant fails to show? Thx.

         
    • since 2 days ago, I am unable to enable my wireless card.
      Adding a new user to tho the user list doesn't work :(

      When I get my card running again, I will post a new message.

      Thanks for your help anyway.