Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

autogen.sh not creating configure

Help
Timothy
2012-12-06
2013-04-24
  • Timothy
    Timothy
    2012-12-06

    I'm using Fedora(64bit) 17. Help please :3

     
  • Doomsday
    Doomsday
    2012-12-06

    I understand your disappointment, however could you be more explicit ?

     
  • Timothy
    Timothy
    2012-12-08

    $ ls
    AUTHORS     BUGS       configure.ac  INSTALL  Makefile.am  po      README.ubuntu  TODO  win32       wscript
    autogen.sh  ChangeLog  doc           LICENSE  NEWS         README  src            waf   wired.doxy  xgettext_wired
    $ ./autogen.sh
    + rm -rf config
    + rm -f aclocal.m4 configure config.log config.status
    + rm -rf 'autom4te*.cache'
    + rm -f libtool
    + rm -f ABOUT-NLS
    + rm -rf intl
    + mkdir config
    + mkdir intl
    + autopoint -f
    ./autogen.sh: line 30: autopoint: command not found
    + set +x
    $ ls
    AUTHORS     BUGS       config        doc      intl     Makefile.am  po      README.ubuntu  TODO  win32       wscript
    autogen.sh  ChangeLog  configure.ac  INSTALL  LICENSE  NEWS         README  src            waf   wired.doxy  xgettext_wired
    $

     
  • Doomsday
    Doomsday
    2012-12-10

    It seems that you're missing autopoint binary on your system.
    It is part of gettext-devel on Fedora, so I will suggest you to install the gettext-devel package.

    Keep going

     
  • Timothy
    Timothy
    2012-12-17

    That helped thank you.

    Now configure is having problems locating FLAC++, I have the devel package installed, so I'm thinking it's a 64 bit or fedora-specific error. =/

     
  • Doomsday
    Doomsday
    2012-12-18

    Try to disable codecs to command line :
    ./configure -disable-codecs