Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

#40 Rename DIFFITEM::IsSideLeft() and IsSideRight()

closed-fixed
Kimmo Varis
None
7
2007-01-06
2006-05-09
Kimmo Varis
No

DIFFITEM::IsSideLeft() and IsSideRight() are highly
confusing function names. They are just totally wrong.
Name suggests they tell if item is *ALSO* in left- or
right side.

But in reality they return if item is left-side-only or
right-side only.

This confusion alone has caused many bugs. And even
some regressions in stable releases...

Discussion

  • elsapo
    elsapo
    2006-10-08

    Logged In: YES
    user_id=1195173

    BTW, I think I submitted an earlier patch to fix these, but
    I think you never accepted it because you never reviewed
    whether the comments I added were sufficient.

     
  • Kimmo Varis
    Kimmo Varis
    2007-01-05

    the patch

     
  • Kimmo Varis
    Kimmo Varis
    2007-01-05

    Logged In: YES
    user_id=631874
    Originator: YES

    Attaching a patch to rename:
    isSideLeft() to isSideLeftOnly()
    isSideRight() to isSidelRightOnly()

    File Added: RenameDiffItemFuncs.zip

     
  • Kimmo Varis
    Kimmo Varis
    2007-01-05

    • assigned_to: nobody --> kimmov
     
  • Kimmo Varis
    Kimmo Varis
    2007-01-06

    Logged In: YES
    user_id=631874
    Originator: YES

    The patch is of course just wrong. It changes the name, but does not change the check the function does. I don't know what I was thinking of...

     
  • Kimmo Varis
    Kimmo Varis
    2007-01-06

    Logged In: YES
    user_id=631874
    Originator: YES

    Forget my last comment - just shows how confusing this can be.

    The patch is correct and I'll commit it today.

     
  • Kimmo Varis
    Kimmo Varis
    2007-01-06

    Logged In: YES
    user_id=631874
    Originator: YES

    Patch committed to SVN trunk.
    Completed: At revision: 4014

     
  • Kimmo Varis
    Kimmo Varis
    2007-01-06

    • status: open --> closed-fixed