#1035 Directory Window Mislabels Files as Different

Branch_+_Trunk
open
nobody
GUI (515)
5
2005-12-15
2005-11-10
Randall Million
No

The directory window will label files as different
which are only different by ignored lines. Double
clicking on the file will show that the files are
identical.

This bug was not present in 2.2.4.0.

Discussion

1 2 > >> (Page 1 of 2)
  • Kimmo Varis
    Kimmo Varis
    2005-11-11

    • milestone: --> Branch_+_Trunk
    • status: open --> open-works-for-me
     
  • Kimmo Varis
    Kimmo Varis
    2005-11-11

    Logged In: YES
    user_id=631874

    Do you have "Quick contents" or "Modified date" as compare
    method in Options/Compare settings? These two compare
    methods have no idea about linefilters in folder compare and
    as such label files different. Quick contents is faster
    because it skips things like linefiltering.

    If you change compare method to Full Contents then files
    should be labeled identical.

    Yes, this fact was missing from manual too, I've added it to
    2.4.2 release's manual.

     
  • Logged In: YES
    user_id=420531

    The file compare method is full contents...I didn't want
    modification date and I have no idea how Quick Contents is
    different.

    So, with "Full Contents" selected (in the "Options..."
    dialog), the directory window shows the fiels as different,
    but when in reality they are identical when ignoring the
    linefilters.

     
  • Kimmo Varis
    Kimmo Varis
    2005-11-12

    • status: open-works-for-me --> open
     
  • Kimmo Varis
    Kimmo Varis
    2005-11-12

    Logged In: YES
    user_id=631874

    Ok, thanks for the information.

    I remember we had this kind of bug in some beta/experimental
    releases, but I cannot reproduce this now with 2.4.0 stable
    release.

     
  • elsapo
    elsapo
    2005-12-04

    Logged In: YES
    user_id=1195173

    I'm not clear what version of WinMerge is being discussed
    here; did submitter say what version?

     
  • Logged In: YES
    user_id=420531

    Error was first noted in version 2.4.0.0
    I have not checked to see if the error is still present in 2.4.2.0

     
  • elsapo
    elsapo
    2005-12-04

    Logged In: YES
    user_id=1195173

    Could you check if error is in the latest experimental
    release (2.5.0.2)?

     
  • Logged In: YES
    user_id=420531

    This was fixed in 2.4.2.0.

     
  • elsapo
    elsapo
    2005-12-05

    • status: open --> closed
     
  • elsapo
    elsapo
    2005-12-05

    • status: closed --> closed-fixed
     
  • elsapo
    elsapo
    2005-12-05

    Logged In: YES
    user_id=1195173

    Closing as Fixed

     
  • elsapo
    elsapo
    2005-12-05

    Logged In: YES
    user_id=1195173

    Also, thank you for bug report & testing & reporting on new
    version.

     
  • Logged In: YES
    user_id=420531

    I know I checked and it worked before...but I tried again
    with some new files and this is still broken. (Even in
    2.5.0.3, unicode and non.) Perhaps it is a file size issue
    (mine are about 60K lines.) Is there any testing I can do
    (since I am not sure that I can send the files to you).

     
    • status: closed-fixed --> open
     
  • elsapo
    elsapo
    2005-12-15

    Logged In: YES
    user_id=1195173

    Ah, yes, there is a file size issue. Files larger than a
    couple of megabytes are compared with the QuickCompare
    algorithm, which does not use line filters.

    You can switch between QuickCompare and FullCompare in
    Edit/Options/Compare/File Compare method, but large files
    will still use QuickCompare instead of File Compare.

    I think that the size cutoff can only be adjusted in the
    registry -- under

    HKEY_CURRENT_USER\Software\Thingamahoochie\WinMerge\Settings

    Value name: QuickMethodLimit

    Can you try to see if moving that limit affects your
    observance of this bug?

     
  • elsapo
    elsapo
    2005-12-15

    Logged In: YES
    user_id=1195173

    If this turns out to be the large file QuickCompare
    optimization, I think we should put a FAQ into the WinMerge
    FAQ about this.

     
  • Kimmo Varis
    Kimmo Varis
    2005-12-15

    Logged In: YES
    user_id=631874

    Oh, I forgot linefilters.. :(

    Its mentioned in manual:
    http://winmerge.org/2.4/manual/comparedirs.html

    Look for two paragraphs above caption
    8.1. Folder Compare Statepane

     
  • elsapo
    elsapo
    2005-12-15

    Logged In: YES
    user_id=1195173

    I'll propose a FAQ entry for this as a new patch.

     
  • Logged In: YES
    user_id=420531

    More so than just a FAQ entry, is it possible to put the size (which can be found
    in the registry) into the preferences where you choose which method to use?

     
  • elsapo
    elsapo
    2005-12-16

    Logged In: YES
    user_id=1195173

    It is possible, but that is an RFE -- and we went ahead and
    implemented the size filtering to gain the optimization,
    even though we've not addressed the GUI. We figured we'd put
    in a registry entry so power users can adjust it now.

     
  • Kimmo Varis
    Kimmo Varis
    2005-12-17

    Logged In: YES
    user_id=631874

    The fact is we need that limit for comparing bigger files.

    Option for that limit is mostly just useless. There is no
    way for determining good value. And most people propably
    would just end up setting it to way too high (just to be
    safe), like 10-20 megs.

    Definitely there is some confusion possible with this and
    filtering. But I think we should handle that with some UI
    hints about filtering not applied than needless option.

     
  • elsapo
    elsapo
    2005-12-17

    Logged In: YES
    user_id=1195173

    We could put up a warning message box when the user diffs
    some files and at least one is above the limiit, and the
    user had Full Compare turned on.

    Everyone is going to check the 'Do not tell me again', I
    expect, but at least they'll get told once :)

     
  • Logged In: YES
    user_id=420531

    I have reset my registry value to something that should take care of the
    problem. Why is a limit needed for comparing bigger files? Is this a benefit to
    the user or the developer?

    Is there a possibility of changing the file compare status in the window from
    Identical to something like:
    * Identical
    * Identical (filtered lines ignored)
    * Different, line filters disabled for this file

    I feel at the root this bug breaks established HMI and does something that
    the user is not expecting, and could not reasonably by expected to guess just
    based on the application. I haven't read the manual, but I shouldn't have to.

     
1 2 > >> (Page 1 of 2)