Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

#10 guitest.dll error in version 1.55

open
nobody
None
5
2008-08-21
2008-08-21
Anonymous
No

When using activestate perlapp to compile a perl script using guitest 1.55 the following error is displayed when the target exe is run on another computer: /auto/ Win32/GuiTest/GuiTest.dll' for module Win32::GuiTest: load_file:The specified module could not be found at C:/Perl/lib/DynaLoader.pm. This problem does NOT occur when using guitest version 1.50.5.

perapp version is 5.3.0
perl version is 5.8.6

Discussion

  • Dmitry Karasik
    Dmitry Karasik
    2008-10-04

    I have ActiveState build 1001, can't reproduce your problem, as I don't have perlapp. I understand that this isn't much help, but possibly you'll be able to identify why exactly this problem happens, and possibly send a patch?

     
  • I had the same problem with GuiTest 1.55

    I have VS6 and perl 5.7 on the first and install Win32::GuiTest 1.55.
    Install Komodo and compile my script by perlapp and ALL work without error!!!
    Then I install VS2008 and perl 5.8 ): try install Win32::GuiTest 1.55 again and compile the scripts by perlapp run exe and get the same error. Copy site\lib\auto\Win32\GuiTest\guitest.dll from first instllation and compile than run exe again - ALL works!!!

     
  • I had the same problem with GuiTest 1.55

    I have VS6 and perl 5.7 on the first and install Win32::GuiTest 1.55.
    Install Komodo and compile my script by perlapp and ALL work without error!!!
    Then I install VS2008 and perl 5.8 ): try install Win32::GuiTest 1.55 again and compile the scripts by perlapp run exe and get the same error. Copy site\lib\auto\Win32\GuiTest\guitest.dll from first instllation and compile than run exe again - ALL works!!!

     
  • I had the same problem with GuiTest 1.55

    I have VS6 and perl 5.7 on the first and install Win32::GuiTest 1.55.
    Install Komodo and compile my script by perlapp and ALL work without error!!!
    Then I install VS2008 and perl 5.8 ): try install Win32::GuiTest 1.55 again and compile the scripts by perlapp run exe and get the same error. Copy site\lib\auto\Win32\GuiTest\guitest.dll from first instllation and compile than run exe again - ALL works!!!