Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

Only 0.7.5 Works

Help
markb
2011-05-20
2013-01-27
  • markb
    markb
    2011-05-20

    Hi, I'm pretty new to Linux and am experimenting migrating to it if I can get my audio apps working. I'm running the Windows version of Renoise under Wine 1.3.20  with Ubuntu 11.04 and jackd 1.9.7.
    I have tried the different versions of winasio with the following results:

    0.9 .0 - Hangs when I select asio in Renoise. Have to kill it to stop.
    0.8.1 - Accepts asio but the sound is totally distorted (like hard clipping) I can't find anywhere to adjust the volume as my USB soundcard does not have any controls in  alsamixer.
    0.7.5 - works fine, audio plays normally.

    Any suggestions?  Thanks

     
  • I'd suggest trying with JACK1, as lately I've gotten some bug reports regarding JACK2 and winasio. JACK1 should work equally well or maybe even better and might even offer lower latency than JACK2.

    Am trying to figure out what is wrong but don't have much time at the moment.  I downloaded the demo of renoise, but unfortunately it doesn't allow me to select the ASIO driver.  Have contaced the devs to ask for a test copy.

     
  • FWIW, I just got a nfr copy of renoise and am running it with wineasio 0.9.0 and jack1.  I did have to add "#define ASIOST32INT 1" to the top of asio.c to force it to use 32bit Int instead of Float.  Probably the reason that it is distorted, but I have never looked at the 0.8.1 source code, so don't know if that is the problem.  I have also found out lately that there are problems between wineasio and jack2 at lower buffersizes.  If you need to use jack2 try setting a buffersize of 1024 or higher.

     
  • markb
    markb
    2011-05-20

    Thanks for your help, it's now working!  I was using Jack2 as it was listed in the package manager and I'd just assumed it was a newer version. I changed to Jack1, it was still distorted with 0.90 so added the #define statement and is now perfect. I'm impressed by how well it works with low latency.

     
  • Cool, happy to hear!  Well the JACK1/2 situation is a little muddy, but they are differing ABI compatible implementation of the same API. JACK1 is actually the reference implementation, and offers half the output latency at the same buffer setting.  It seems likely that both will continue to be developed. I am looking to see if I can find the bug with JACK2.  You might also be interested in a patch I made for wine, which allows wine to run threads at elevated priority, should help with lowlatency.  You can find it at: http://dl.dropbox.com/u/879835/wine-rt-101107.patch

    Have fun :)

     
  • I forgot to say that if you are runing audio on ubuntu, you ought to consider to add the repos from kxstudio, see: http://kxstudio.sourceforge.net/mediawiki/index.php/Main_Page  It will most likely make your life at lot easier with audio apps…

     
  • markb
    markb
    2011-05-21

    Thanks for the info, I've just read the wiki about jack1/jack2 and it's an interesting situation. Anyway, in my testing I found something odd. Renoise's samples play back fine but when I loaded a VST it seemed to hang the audio system as it would not play and the transport no longer worked. Out of interest I tried removing Jack1 and installed Jack2 again and this time it worked and the VST's played ok. So it seems compiling against Jack1 allowed 0.90 to work with Jack2 for me.

     
  • Think I found the bug in wineasio with JACK2.  If you can, please try to get the code from the git repo:  git://wineasio.git.sourceforge.net/gitroot/wineasio/wineasio  If you don't know how to use git, just install it, and cd to where you keep your source code and do: git clone git://wineasio.git.sourceforge.net/gitroot/wineasio/wineasio

    Hopefully this will fix the JACK2 problem.

    Might I ask why you would want to use renoise in wine, when there is a native linux version?  Tried the native linux one, and it worked a lot better :)

     
  • markb
    markb
    2011-05-22

    Happy to say that I recompiled with this version and everything is working as expected :)

    As you point out there is a perfectly usable native version of Renoise so it seems like an act of insanity to struggle to get the Windows version working. The only reason I'm doing it is I have a small investment and fondness for a selection of Windows VST's and this seems the best way at the moment to get them working within Linux with a song file that I can transfer over to Windows when my CPU overheats from all the emulating its doing.

     
  • jddfr
    jddfr
    2011-08-27

    Well, strange - git version does not work for me with jack2 (on debian/unstable, exact version is 1.9.7~dfsg-1). But 0.7.5 is ok -;

     
  • I have been using WineASIO 0.7.5 with Ubuntu 11.04 and Jack 1.9.6 and it would hang until I stopped using a 48000 sample rate.  This sample rate should work (and always did in the past) with my audio card which is a 48000 card by default, but can also do 44100, and that sample rate does not seem to have any (or very few) problems.