Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

Problem w/ 'high ASCII' characters in ...

Help
2013-02-02
2013-04-18
  • Czerno Bill
    Czerno Bill
    2013-02-02

    First thing I wish to thank you for the great bash port !

    Problem, apparently winbash discards any non strict US ASCII characters (i.e. codes above 127) before processing the command line  or passing it to an external *ix command, e.g. :

    bash$ echo Th‚orŠme è1
    Thorme 1
    bash$

    This is of course extremely annoying for non-US users. Cannot process file names with "foreign" characters ! Is it fixable by proper configuration on the user's (=my) side ?

     
  • Joerg Matysiak
    Joerg Matysiak
    2013-02-20

    czernobyl,

    we can reproduce the problem with german umlauts, but sadly have currently no solution for you.
    It's likely that this can only be fixed in the code, I'm not aware of any configuration settings that could fix that.

    I'm sorry, but currently we don't have the resources to implement such a fix.

     
  • Czerno Bill
    Czerno Bill
    2013-02-22

    Matysiak! thanks for confirming that this is indeed a problem in the code. I'm sorry to hear you
    will not be fixing it - this defect makes working with winbash file management commands hazardous
    on a partition where files exist having 'umlauts' in their names.

    Of course I can understand you having resource problems; I do hope you may find some time to
    review your code and, at least, locate the parts that would need updating and evaluate the amount
    of work involved in a fix.

    sincerely,
    Czerno