Korean language support

Anonymous
2012-11-23
2013-01-02

  • Anonymous
    2012-11-23

    Does Whonix feature Hangul(Korean) support? Is there any package I can download that will add this feature?

     
  • adrelanos
    adrelanos
    2012-11-24

    Thanks for your interest! There is a good news and a bad news.

    Bad news:
    I am the only Whonix developer. No one else willing to contribute so far. Most languages asked support for I don't understand and can therefore barely check if they're working.

    Maybe it's a bit too early for out of the box multi language support in Whonix. Out of the box multi language support is quite difficult to add.

    Good news:
    Whonix is based on Debian, meaning if you learn how to do it on Debian, you'll also know how to do it in Whonix:
    https://sourceforge.net/p/whonix/wiki/About/#whonix-is-based-on-debian-virtualbox-and-tor

    There are already instructions how to change KDE the language in Whonix-Workstation:
    https://sourceforge.net/p/whonix/wiki/Language/#system

    For Korean fonts try the ttf-unfonts-core package.

    Instructions for Tor Browser:
    https://sourceforge.net/p/whonix/wiki/Language/#tor-browser

     
    Last edit: adrelanos 2012-12-14

  • Anonymous
    2012-12-14

    I think we need to support Chinese because of hard sensorships.

     
  • adrelanos
    adrelanos
    2012-12-14

    I updated the links in my previous post.

     
  • adrelanos
    adrelanos
    2012-12-14

    I think we need to support Chinese because of hard sensorships.

    Without any help this will be difficult for me.

    Did you read and try my first answer in this thread?

     

  • Anonymous
    2012-12-19

    There is a problem. Installing nabi, easy Korean XIM, was failed because of locales.

    Is there any way to install nabi?

     

  • Anonymous
    2012-12-24

    Uh uh. There is a problem. I can't run "dpkg-reconfigure locales". I should change locales to use nabi! I tried "sudo apt-get install dpkg-reconfigure" but it failed.

     
  • adrelanos
    adrelanos
    2012-12-24

    Must run as root.

    sudo dpkg-reconfigure locales
    
     

  • Anonymous
    2013-01-02

    How to use korean in Whonix

    1. Open konsole
    2. sudo apt-get update
      3. apt-cache search kde-i18n
      4. sudo apt-get install kde-l10n-ko
    3. sudo apt-get install ttf-unfonts-core ttf-unfont-extra
    4. Open system settings and set eungulim as kde's font
    5. Open konsole and sudo dpkg-reconfigure locales
    6. Set "ko KR.UTF-8 UTF-8" as Default locale
    7. Apt-get install nabi
    8. Restart your Whonix-workstation and start nabi
    9. You can write ad read Korean now.