Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

#11 option to build only against gtk or qt4

closed-fixed
nobody
None
5
2010-12-02
2010-11-30
Anonymous
No

Wepcrackgui should have an option to build ONLY against gtk (gtk-sharp2) or against qt4 (qyoto) toolkit.
For the moment you can't build only against qt4 toolkit because the configure script will search anyway for the package 'gtk-sharp2' :

Looking for required packages
Checking for package 'gtk-sharp-2.0'.. ERROR: Package named 'gtk-sharp-2.0' >= 2.12.10 not found.
Try adjusting your PKG_CONFIG_PATH environment variable.

If this is normal, the file 'Dependencies' on the root directory should be modified to include gtk-sharp-2.0 as a global dependency

Discussion

  • criser
    criser
    2010-12-02

    • status: open --> closed-fixed
     
  • criser
    criser
    2010-12-02

    This is fixed since commit 43134ef5cc7e7519ed4710c4bf534a85f0f6e953.
    Use ./configure --config={DebugQt|ReleaseQt|DebugGtk|ReleaseGtk} to choose between the Qt and Gtk frontend.