Yes, my Fasterfox version is significantly older: 0.7.9 is what I am at now.
 
--Hank
-----Original Message-----
From: webware-discuss-admin@lists.sourceforge.net [mailto:webware-discuss-admin@lists.sourceforge.net]On Behalf Of Christoph Zwerschke
Sent: Friday, January 13, 2006 3:28 AM
To: webware-discuss@lists.sourceforge.net
Subject: Re: [Webware-discuss] Admin password rejected

 Sender ALLOWED   [ Remove ]  [ Block ]    details 
Vanquish Anti-Spam Control Panel

 
Hank Freeman wrote:
> Mystery solved.  I am using the "Faster Fox" plug-in.  It does pre-fetching
> of links on a page.  With the setting at "Turbo" (most aggressive) this
> authentication fails.  For me, it fails at all settings above "Courteous".
> (YMMV)  Dialing back the aggressiveness of the plug-in resolved this issue.
> Thanks again for all the help.

Thank you for the feedback. Now the reason for this problem is clear:
Fasterfox loaded all the other Admin links in the background which
resulted in opening a lot of login pages. Each call of the login page
changed the login id in the session, so that the original login id did
not fit any more.

If I understand correctly, the login id is used to ensure nobody can
circumvent the login page (e.h. by providing user and password directly
as parameters in the URL). So I left the login id mechanism in the code,
but changed it so that no new login id is created if there is already
one in the current session. I have checked that in already. The Example
and Admin pages are not really important, but intended to give people an
idea how things should be done; so they should do it correctly.

But there is still one thing that I do not understand: I checked this
with Fasterfox, and I noticed these two bugs/features:
1) Fasterfox makes the links lowercase before pref etching them. It does
not work at all if links contain uppercase letters and are case
sensitive (which is the case for the Webware Example/Admin pages!)
2) Fasterfox checks whether links have an extension that looks like a
static page (e.g. ".html"). If they have no extension (which is the case
for the Webware Example/Admin pages), then they are not prefetched.
So only after I changed these two things in Fasterfox, I could reproduce
the described behavior. Are you using a different version of Fasterfox
(I checked with 1.0.2 which seems to be current).

-- Christoph


-------------------------------------------------------
This SF.net email is sponsored by: Splunk Inc. Do you grep through log files
for problems?  Stop!  Download the new AJAX search engine that makes
searching your log files as easy as surfing the  web.  DOWNLOAD SPLUNK!
http://ads.osdn.com/?ad_id=7637&alloc_id=16865&op=click
_______________________________________________
Webware-discuss mailing list
Webware-discuss@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/webware-discuss