Can anyone get this to compile?

In the past, I just moved over a good module from another system, but now I'm on a 64bit box.

Here's what I get:

# make
/usr/bin/apxs2 -c mod_webkit.c
/usr/share/apr- 1.0/build/libtool --silent --mode=compile --tag=disable-static x86_64-linux-gnu-gcc -prefer-pic -DLINUX=2 -D_GNU_SOURCE -D_REENTRANT -I/usr/include/apr-1.0 -I/usr/include/openssl -I/usr/include/postgresql -I/usr/include/xmltok -pthread     -I/usr/include/apache2  -I/usr/include/apr- 1.0   -I/usr/include/apr-1.0 -I/usr/include/postgresql  -c -o mod_webkit.lo mod_webkit.c && touch mod_webkit.slo
mod_webkit.c: In function 'wksock_open':
mod_webkit.c:217: warning: passing argument 4 of 'apr_socket_create' makes integer from pointer without a cast
mod_webkit.c:217: error: too few arguments to function 'apr_socket_create'
apxs:Error: Command failed with rc=65536
.
make: *** [mod_webkit.o] Error 1