I've been using Webware for over 2 years on windows, any really have had not problem.

I tried to install in on a linux box and it fails.

I installed it as it was download. I have Python 2.3.4,
Webware 0.9.1

The result of a "uname -a" on the linux box is:
Linux resdev1.dev.oclc.org 2.6.9-34.ELsmp #1 SMP Fri Feb 24 16:56:28 EST 2006 x86_64 x86_64 x86_64 GNU/Linux

I initially left the WebKit AppServer.config file as it was installed:
Host = '127.0.0.1'
(This was the recommented procedure to verify a correct install.)

When trying to connect with the server with a web browser on another platform and an address:
http://resdev1.dev.oclc.org:8080/

The server has no response.

I changed the AppServerconfig file:
Host = 'resdev1.dev.oclc.org'

And get the following error when I attempt to connect the same way:
.
.
.
ImportSpy activated (using new import hooks).
AutoReload Monitor started, polling every 1 seconds.
Creating 10 threads..........
Listening for Adapter on ('resdev1.dev.oclc.org', 8086)
Listening for HTTP on ('resdev1.dev.oclc.org', 8080)
Ready (0.18 seconds after launch).

Traceback (most recent call last):
  File "../WebKit/ThreadedAppServer.py", line 865, in run
    server.mainloop()
  File "../WebKit/ThreadedAppServer.py", line 235, in mainloop
    handler = self._handlerCache[serverAddress].pop()
KeyError: ('132.174.113.158', 8080)
Exiting AppServer due to above exception.
ThreadedAppServer is shutting down...
Stopping AutoReload Monitor...
Autoreload Monitor stopped.
AppServer is shutting down...
Application is shutting down...
Application has been succesfully shutdown.
AppServer has been shutdown.

I've used the Webware for  Widows for many application.
(Host = '127.0.0.1')

Never experienced this problem.

Is it something simple I overlooked?

Tom Dehn
OCLC Inc.