Http port (e.g. 80 or 8080)

Help
Peter
2009-01-27
2013-04-22
  • Peter
    Peter
    2009-01-27

    I am planning to access Webhuddle behind an Apache who is going to handle the ssl and some authentication part.

    I have tried to setup Webhuddle to listen on port 8080.  Anyway I always get a redirect to https/8443 although I have deleted the redirects to port 8443 in
    jboss/server/default/deploy/jbossweb-tomcat50.sar/server.xml
    and
    jboss/server/all/deploy/jbossweb-tomcat50.sar# more server.xml

    Any hints how I can proceed to get pure http?

    Best regards
    Peter

     
    • John McCaughey
      John McCaughey
      2009-02-02

      Sorry for the delay!  Are you building from the source or using the pre-built binary?  The pre-built binary is getting old (hope to update it soon -- apologies) so I suggest grabbing the source and building from that.

      To disable ssl there is a property that must be set:

      webhuddle.property.ssl.required=false

      Please post again if this doesn't fix the issue -- thanks!

       
      • KK
        KK
        2009-09-01

        Hello, I have build the source, changed server.xml changed the property but when I make a request to http://localhost:8080 the browser redirects to https://localhost

        Any idea?

         
    • HI , I have built the ear file from source code and still facing this issue. I have removed the redirect to port from server.xml. and i also gave webhuddle.property.ssl.required=true in webhuddle.properties under jboss/bin. Please help me with this.

       
    • Am sorry...i meant webhuddle.property.ssl.required=false